Solved

Comp don't start with one of my Graphic card

I was playing League of legends (not a top graphic game) with two Asus Nvidia GTX760 DirectCUII OC 2GDDR5 In SLI When my computer shut itself. I tried to restart it but nothing.It open a second and shut .All the light are on and if i want to try to restart it again a have to put the PSU off until the comp load off the power and turn the PSU on and the same thing append. i remove my bottom card same thing append.Replace the top card with the removed one and it start! when i try to put the card again it doesn't start .... but all light are on and everything is plug correctly (I did my setup myself and it work perfectly for 2 month) Do you thing my Graphic card is dead?

My comp:
Asus M5A99X EVO R2.0
AMD FX8150 8core @ 4.4MHZ
4 X 4G DDR3 1600 kingston HyperX
2 X Asus Nvidia GTX760DC2OC 2GD5
Corsair TX850W PSU
Corsair H100I (CPU cooling)
3 answers Last reply Best Answer
More about comp start graphic card
  1. I just retried it and saw some spark ... i'm pretty sure it's dead!
  2. Best answer
    Try the possible dead card in the first x16 slot and see if it still works.
    If not, what can I say, GG.

    If still under warranty, which is 3 years you can 'try' to ask for replacement.
  3. IDontUnderstand said:
    Try the possible dead card in the first x16 slot and see if it still works.
    If not, what can I say, GG.

    If still under warranty, which is 3 years you can 'try' to ask for replacement.


    I'm sure the card is dead soo like you said i will try the warranty! thk for the reply!
Ask a new question

Read More

Graphics