Usb device not recognized windows 8

I just got a new Motherboard and CPU, and my microphone was working perfect with my old Motherboard and CPU, but after i installed my new Motherboard and CPU, whenever i plug my microphone in the USB, i just get usb device not recognized. i searched and tried everything on the internet, nothing helped. Please help me.

CPU: i7 4770k
Motherboard: Maximus vi hero
Microphone: Razer megalodon.

Just tell me if you need more information.
12 answers Last reply Best Answer
More about usb device recognized windows
  1. Go to this site:,78,37

    That is the link to software and drivers for the microphone. Install them, then plug the mic in. That may work.
  2. Didn't work :/
  3. I have no idea if this is the case, but when installing new hardware it is VERY important to follow the instructions that came with it to the letter. A lot of hardware that I have bought throughout the years has very explicit instructions to NOT plug the device in without first installing the software/drivers that come with it. If you did this, try uninstalling all associated software and drivers with the product, then re-install following the manufacturers exact instructions. I have found this to work in the past.
  4. Didn't work :(
  5. Can i be like motherboard drivers?
  6. Oliversisu said:
    Can i be like motherboard drivers?

    I don't think so. I have had devices do this in the past and have even had a couple that I never did figure out. It is beyond frustrating, I know. I will keep racking my brain and search online for an answer. Surely there is SOMETHING out there.
  7. Best answer is something that worked on the identically same problem.

    UPDATE: This is a Windows 8 problem. I have since ran across several people who have had virtually the same thing happening, only with different devices. I have also seen this remedy (the disabling of USB 3.0) solve the issue of a wireless keyboard having a range of only 1-2 feet from the USB dongle. Once USB 3.0 was disabled, range of the wireless keyboard was dramatically increased.
  8. So try to go in BIOS and disable xHCI or what?
  9. Oliversisu said:
    So try to go in BIOS and disable xHCI or what?

    Give it a shot. If it doesn't work just change it back.
  10. Okay, i will try.
  11. It worked, thank you so much.
  12. Oliversisu said:
    It worked, thank you so much.

    Awesome! Glad to help. :D
Ask a new question

Read More

Microphone Windows 8 Components CPUs Motherboards USB3 USB Connector USB