Sign in with
Sign up | Sign in
Your question
Solved

My HDD is not recognised anymore after the install of SSD

Last response: in Storage
Share
March 15, 2014 1:20:20 AM

I've encountered this problem and i've been struggling for two nights to find an answer but i'm all out of ideas so i will be asking you for your opinion on this issue.

Please have patience and keep reading. I know it's a long lecture but i really need help here:) 

Recently i bought an 120gb samsung 840 evo SSD. everything went great so far back then: it comes with some "migration sofware" that simply clones your copy of windows from your C: partition onto the SSD. I even managed to boot the windows from the SSD and so, i thought: why not delete the partition from the old windows and unite the unallocated space with the rest of the 1tb hdd (WD Blue WD10EZEX). So i used a program called "Minitool Partition Wizard" to do just that. The windows restarted, as it was supposed to, and before the log on, the process starter. It looked like it was going to take a whille so i went walking around the house. When i returned to check the computer, the screen was frozen at the motherboard screen. I tried to enter bios but the button didn't work. Well, the keyboard was connected and when i pressed the button it made a sound like it usually does before entering bios but.. it just didn't do anything.

I tried to restart over and over again. even switched the cables between the HDD and the SSD, nothing seemed to work. At some point i tried with only the HDD, but same result: frozen motherboard screen. Then i tried with only the SSD. Everything went great, nice and fast. So i used this chance to install a new OS on the SSD, as my settings and documents were saved on the HDD.

Then i remembered that somewhere in my house i have an HDD to usb adaptor and i used it to connect the problematic hdd. Guess what? it worked just fine. I even made some settings, installed some programs but then when i restarted it frozed again. Could it be the HDD connected trough usb?, i thought. So i removed the usb device and everything worked again.

So basically, i can use my HDD but i can't restart with it. But it's not my WD Blue that's the problem, as i tried with another HDD (WD Green 1tb) and it also didn't work.

Also i made disk checks to see if there really is a problem in the HDD's sectors and the check returned no bad results.

Please come forward with a solution for me, as i am tired of restarting my computer and having to remove the usb everytime. This is not normal. An internal hdd should be connected trough sata not usb.

Thanks for reading this long, unending post, and thanks in advance for helping me:) 
a b G Storage
March 15, 2014 5:00:41 AM

Have a look at you hdd in Disk Management while it's connected by USB and see what partitions are on the disk, also try booting into safe mode and see if that works...

When you say it is working fine and windows restarted, I'm not sure how you are then getting to the BIOS menu. That should not be possible. Once windows starts to load, you should be long past the BIOS screen...
m
0
l
March 15, 2014 8:02:32 AM

The only way i can see my HDD is if i plug it trough usb after i boot from SSD, when i'm already in windows. If i plug it before starting the computer it freezes (on sata or trough usb i get the same result: freezes at that motherboard screen). And i can get to the bios menu but only with just the SSD connected. I made all kinds of settings and nothing seems to work.
Lately i've set the boot order to just launch the UEFI settings panel, i disabled the rest and tried to connect the other HDD, WD Green. It worked, i could boot with that drive, but the same thing with WD Blue doesn't work.. although when i connected it post-motherboard screen i went to disk management like you said and it said that both my SSD and my Wd Blue drives are healthy.

And regarding the safe mode, that doesn't work because of the frozen screen. i could only boot with the ssd and enter the safe mode, but what do i do after?

i'm really out of ideas.. maybe after all it is the hdd's fault.. although the windows sees it if i plug it past the login screen (there is only one partition of 1tb - D: - and it's accessible and everything, so there is still hope for me

if you have any other ideas please let me know
m
0
l
Related resources
a b G Storage
March 15, 2014 9:49:20 AM

When you opened the disk in disk management, did you just have the partition that you would normally see in "my computer", or were there other partitions on the disk? If it is a single partition that takes up the entire disk, there should be one box that takes up all the space, either with a blue bar at the top, or a green one. This is the same no matter if you connect it via USB while the computer is already running or not.

The fact that your disk is working fine via usb is a good indication that you there is not actual problem with the hard drive.

You mentioned that you had used a 3rd party software you edit the partitions on the disk and have had problems with the disk ever since that moment. It is possible that you have used this partition software incorrectly.

When you open the drive in my computer via USB, do you immediately see any folders that you don't recognise?
m
0
l
March 15, 2014 10:15:09 AM

https://scontent-a-lhr.xx.fbcdn.net/hphotos-frc3/t31.0-...

This is what i see, everything looks normal, like in "my computer". There is a single partition that occupies the entire drive (D:) . At first there were two (C: and D: and the ssd one was E:) . I cloned C: on E: and i managed to boot just fine but then i wanted to erase E: (as the C: partition became the SSD one and windows worked just fine) so i deleted E: in that software (Minitool Partition Wizard - which i have successfully used many times before). What i did exactly was to delete the partition E: and to transfer the unallocated space created to the rest of the partition. After that i hit apply, windows restarted, and before the windows log on the process started.. then you know what happened, as i stated earlier.

The drive D: is entirely accessible and everything is like before, and there's no unallocated space left which brings me to the conclusion that the program wasn't faulty, but there's somehow a conflict between WD Blue and Samsung SSD Evo 840. As i understand i'm not the only one experiencing this.

I hope the picture helps somehow, and thanks again for the time invested in researching the problem i'm experiecing and for the quick replies
m
0
l
a b G Storage
March 15, 2014 12:09:05 PM

I'm curious as to why it reads as "D:", "online" and "primary partition" in Disk Management but it appears to be offline in your wizard and lists it as a "logical drive"...

So if you have never used TestDisk before, now might be the time to learn.. Don't be put off buy the command line interface, it's quite simple to use and you mustly just press up and down and enter. Start with the standard intel search but if your serach comes back with only your SSD, try GPT... It appears that something has become corrupt of something is in there that shouldn't be. It's 0300am so I'm gonna go to sleep but there is plenty on youtube to walk you through what you can't get from reading this link and plenty more people on here... I had a similar problem to you the other day, some linux crap got put onto an external ssd and choked up my boots when it was connected. Luckily for me it was just a case of deleting a folder from the ssd from the running desktop and it was all sweet. I didn't hae to use testdisk but it's served me well many times in the past. If worse comes to worst and you really can't be bothered, back up your HDD and wipe it totally clean. It doesn't still doesn't look like a hardware error to me, more like something didn't go as planned when you extended your partition in the wizard...

http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step
m
0
l
a b G Storage
March 15, 2014 12:15:06 PM

PS if TestDisk take you back to having two partitions on this drive, try using disk management to delete your C:, create new volume and either format it as a new volume E: (sure fire method) or delete C: and try to extend your D: partition again. Doesn't always work that way but I often does. I tend not to play with partitions too much when the disk is full of data...
m
0
l
March 15, 2014 11:06:33 PM

I am trying it right about know and i will come back with the result:) 
m
0
l
a b G Storage
March 16, 2014 1:20:44 AM

Oh, this is important, sorry I was tired last night. When I say "C:" in my last reply, I mean the partition on this drive that was originally your C:, NOT the partition marked as C: that is currently on your SSD drive! that will obviously delete your windows partition. Disk Management shouldn't allow it but a bootable partition manager will. Do not do that unless you actually want to reinstall windows.
m
0
l
March 16, 2014 4:10:43 AM

I tried it and i think it found the partition, but there were no files.. i guess i just have to backup my data, format and then see if it works. the only problem is where to find 1tb of free space to put my data on whille doing this. i'll have to see about that
m
0
l
a b G Storage
March 16, 2014 6:44:37 AM

Did you try doing a deeper search?
m
0
l
March 16, 2014 8:01:31 AM

yes.. unfortunately it didn't seem to work. anyway, in a couple of hours, a friend of mine is gonna drop by with his 2th hdd for me to copy al the data on his drive before i format. hope it'll work
m
0
l
March 17, 2014 6:05:33 AM

update: an ugly thing happened yesterday - my friend brought me his 2tb hdd and i installed in in my case and, as usual, i plugged my HDD adaptor's cable post bios, and when i logged in, his drive was showing but mine didn't show any details (like "X gb free of Y gb") and upon double clicking it, it said "this hard drive must pe formated in order for it to work. Obviously i pressed cancel. I tried restarting and now it says: 56.0kb free of 1.38mb.. luckly, somehow, the 3rd party program that got me into this mess recognized it and i asked for "lost partition recovery". Now it has 6 hours and 10 minutes left so it's gonna take a whille. Hope this ends well, i don't want to lose my data.
m
0
l
a b G Storage
March 17, 2014 9:07:49 AM

Just FYI, that same piece of software is being pushed all over these forums by spammers and other people are also losing their partitions. I strongly suggest that you look for a more reputable program if you are not happy with the windows options like Disk Management and TestDisk.
m
0
l
March 17, 2014 9:30:15 AM

as soon as i recover my data i will save it to another drive (i managed to install another one - also trough usb) i will try to forget this software even exists. I would've used Disk Management or TestDisk but in Disk management my drives look like this: https://fbcdn-sphotos-b-a.akamaihd.net/hphotos-ak-prn2/... (E: is the new, external one) whille in TestDisk even after the deeper search my files are nowhere to be found.
Honestly i can't wait for this problem to be over.. hope the format after the files backup will be worth it
m
0
l
a b G Storage
March 17, 2014 9:44:14 PM

What a mess!!! Sorry I can't help you more but I have no intention of touching that software to find out just how well I can ruin my stuff hahaha

So you waited for 7 odd hours for it to rebuild a 600MB partition that you never had in the first place? Brutal!
m
0
l
a c 122 G Storage
March 17, 2014 9:56:15 PM

You may have already done this but have you checked the boot order in the BIOS when you have the HDD installed with the SSD? I only ask because it won't boot with the HDD installed. Could it be that it is trying to boot from the HDD instead of the SSD?
m
0
l
a b G Storage
March 17, 2014 10:05:08 PM

He couldn't even get into BIOS with the drive connected. A number of other users have also suffered from this choice of partition manager and at least one user has been blocked for trying to push it. It's almost certainly infected with something nasty.
m
0
l
a c 122 G Storage
March 17, 2014 10:21:08 PM

Szyrs said:
He couldn't even get into BIOS with the drive connected. A number of other users have also suffered from this choice of partition manager and at least one user has been blocked for trying to push it. It's almost certainly infected with something nasty.


I should have read it more carefully. Thank you for pointing that out. After going back I see where I missed that he couldn't get into the BIOS with the HDD installed.
m
0
l
March 19, 2014 11:33:43 AM

today i completed the file restoration (all ended successfully), i formated the disk (all of this was done with the same program) and it worked! Now i'm checking it for errors and bad sectors before i copy my files back to it. It looks very promising:) 
m
0
l
a c 216 G Storage
March 19, 2014 4:29:01 PM

Hancu Andrei-Ovidiu said:
today i completed the file restoration (all ended successfully), i formated the disk (all of this was done with the same program) and it worked! Now i'm checking it for errors and bad sectors before i copy my files back to it. It looks very promising:) 


Glad to see your progress!

Was the software that worked called "Minitool Partition Wizard"?

Yogi

m
0
l

Best solution

March 20, 2014 5:46:54 AM

Yes. That's the software's name. So the format was successful, the disk check went ok with no errors and the file restoration was a success. After that i booted from the ssd with the hdd connected to sata and it workeed! I'm very satisfied with the result. Works perfectly, as it should.

Thank everyone for your help!:) 
Share
March 20, 2014 5:49:38 AM

In order for the hdd to work again, i had to move my data to another drive, format, and then move the data back. That was the only solution for me, and it worked:) 

Hope this will solve yours too if you're facing the same problem;)
m
0
l
!