Sign in with
Sign up | Sign in
Your question
Solved

ASRock 990FX Extreme3 with a AMD FX-8320 Vishera CPU

Last response: in Motherboards
Share
March 16, 2014 2:16:27 AM

i recently built a new pc but for some reason it wont boot up the case fans come on but the gpu doesnt power on and there's no picture. i remember seeing something about maybe needing a bios update for the cpu to be compatible. could this be the root of all my problems?

Best solution

a c 235 V Motherboard
a c 172 à CPUs
March 16, 2014 2:51:56 AM

No your CPU and mobo should work right out of the box, check cable for proper connection!
Share
Related resources
March 16, 2014 11:41:58 AM

ive made sure the cables were properly connected serveral times but still to response from the card
m
0
l
a c 1215 V Motherboard
a c 909 à CPUs
March 16, 2014 2:55:37 PM

SUPPORT FOR THE FX8320 and FX8350 ON THIS BOARD (ASRock 990FX Extreme3) was pulled due to thermal issues , they are not supported.

Here is the support list for the board.

AM3+ Opteron OS3320SJW4KHK 25W Piledriver 1900MHz 1400MHz 2MBx2 8MB C0 P1.40
AM3+ Opteron OS3380OLW8KHK 65W Bulldozer 2600MHz 2000MHz 2MBx4 8MB C0 P1.40
AM3+ Opteron OS3280OLW8KGU 65W Bulldozer 2400MHz 2600MHz 2MBx4 8MB B2 P1.40
AM3+ FX FD8300WMW8KHK 95W Piledriver 3300MHz 2200MHz 2MBx4 8MB C0 P1.30
AM3+* FX FD8150FRW8KGU(BE) 125W Bulldozer 3600MHz 2200MHz 2MBx4 8MB B2 All
AM3+ FX FD8140WMW8KGU 95W Bulldozer 3200MHz 2200MHz 2MBx4 8MB B2 P1.20
AM3+ FX FD8120WMW8KGU(BE) 95W Bulldozer 3100MHz 2200MHz 2MBx4 8MB B2 All
AM3+ FX FD8100WMW8KGU(BE) 95W Bulldozer 2800MHz 2000MHz 2MBx4 8MB B2 All
AM3+ FX FD6350FRW6KHK 125W Piledriver 3900MHz 2200MHz 2MBx3 8MB C0 P1.30
AM3+ FX FD6300WMW6KHK 95W Piledriver 3500MHz 2000MHz 2MBx3 8MB C0 P1.40
AM3+ FX FD6200FRW6KGU 125W Bulldozer 3800MHz 2200MHz 2MBx3 8MB B2 P1.20
AM3+ FX FD6130FRW6KGU 125W Bulldozer 3600MHz 2200MHz 2MBx3 8MB B2 P1.20
AM3+ FX FD6120WMW6KGU 95W Bulldozer 3500MHz 2000MHz 2MBx3 8MB B2 P1.20
AM3+ FX FD6100WMW6KGU(BE) 95W Bulldozer 3300MHz 2000MHz 2MBx3 8MB B2 All
AM3+ FX FD4350FRW4KHK 125W Piledriver 4200MHz 2200MHz 2MBx2 8MB C0 P1.30
AM3+ FX FD4320WMW4MHK 95W Piledriver 4000MHz 2000MHz 2MBx2 4MB C0 P1.30
AM3+ FX FD4300WMW4MHK 95W Piledriver 3800MHz 2000MHz 2MBx2 4MB C0 P1.30
AM3+ FX FD4200FRW4KGU 125W Bulldozer 3300MHz 2200MHz 2MBx2 8MB B2 P1.20
AM3+ FX FD4170FRW4KGU(BE) 125W Bulldozer 4200MHz 2200MHz 2MBx2 8MB B2 All
AM3+ FX FD4150WMW4KGU 95W Bulldozer 3900MHz 2000MHz 2MBx2 8MB B2 P1.20
AM3+ FX FD4130FRW4MGU 125W Bulldozer 3800MHz 2000MHz 2MBx2 4MB B2 P1.20
AM3+ FX FD4100WMW4KGU(BE) 95W Bulldozer 3600MHz 2000MHz 2MBx2 8MB B2 All
m
0
l
March 16, 2014 7:53:57 PM

shouldnt it still boot up the gpu though?
m
0
l
June 9, 2014 5:44:11 AM

I have exactly the same motherboard and problem as you. try booting off the windows install disk and see if it does anything? It has now booted up my computer normally. Although my graphics card always turned on.
m
0
l
!