Sign-in / Sign-up
Your question

INTEL I217-V ethernet network controller - Windows 7 64 drivers don't work

Tags:
  • Windows 7
  • Drivers
  • Ethernet Controller
  • Intel
Last response: in Windows 7
March 20, 2014 4:54:09 AM

Hi,

Gigabyte GA-Z87x-D3H with Intel I217-v Ethernet Controller
Running windows 7 64bit

I've been trying to get these drivers to work for a while now , I've tried everything but still Windows keeps giving me error code 10 Device wont start. It recognises the controller but there's something wrong with the drivers. In device manager i get the yellow triangle with the exclamation mark. This is also a new pc build.

I installed the drivers for the Intel I217-V from the mobo CD,the latest version from the Gigabyte website and Intel website. These all did not work. The port's led light is working as it should so the the ethernet controller is not broken.

I updated the BIOS from F7 to F8 , no change.
I even tried bypassing the normal install procedure and used this way
http://hardforum.com/showthread.php?t=1772066
http://www.ivobeerens.nl/2013/06/24/enable-the-intel-i2...
Here you edit the correct .inf file suitable for your OS. Instead of the NDIS63 Win8 driver folder , I used the NDIS62 folder ( wich is suitable for win 7 64 and edited out the same stuff in the .inf file) installed it once with .exe and once with "update driver" selecting the edited .inf file and installing. Still did dint work either
After multiple tries , nothing.

I've tried everything uninstalling, reinstalling ,differnt versions etc.
I dont know anymore... please help me ! thanks in advance!

More about : intel i217 ethernet network controller windows drivers work

March 20, 2014 11:43:17 AM

please help... thank you! :) 
m
0
l
a b $ Windows 7
March 21, 2014 1:56:14 AM

When installing new drivers, did you uninstall the old from Add/Remove Programs and uninstall the eth controller from Device Manager? If not, do so then reboot.
m
0
l
March 26, 2015 12:48:37 PM

gogobrent said:
please help... thank you! :) 


Did you manage to figure out a solution?
I have the same motherboard and problem as you and I can not figure out how to get it to start working again.
m
0
l
Related resources