.exe installer files won't run on my computer

When I attempt to open one of a few installers, nothing happens. Whether I click the installer or right-clicking and clicking Run as Administrator, there is no response. After some searching, I found that it does appear on the Task Manager as a running process that takes up 0.1mbps of memory, but it does nothing else. Closing it out is possible, but trying again produces the same result. Trying to open multiple installers does not create a conflict - they just appear as multiple processes. Restarting also does nothing.

There are a couple installers that do work fine, one of which shares a manufacturer with one that doesn't work. I compared the properties of those two, and found only one difference - the working one was a 10MB file, while the not-working one was only 8MB. However, another working installer has only 4MB, and yet another (made by the same manufacturer as the first two) has the same size as the not-working one, so I don't think it's affected by size.

I also just tried turning off my internet and running an offline version of the same not-working installer. Again, nothing happens. I don't think it gets far enough into the process to be affected by a firewall or internet connection. It just refuses to open.

For the record, this program is one that I uninstalled recently in an attempt to fix a different problem. That was when I first noticed the problem. However, I have tried three other programs that I've never installed on my computer that don't work. I've also tried reinstalling a different program from a different manufacturer, and that worked. Haven't yet found a new program that works, but that could be easily from lack of trying.

On this program I'm trying to reinstall: I do have another version of it installed. It could be causing an issue, but I'm unwilling to uninstall it for fear of it causing a repeat problem (the installer works for now, but I don't want to push my luck), and I doubt it's the problem anyways - after all, that one worked fine when I installed it the first time, and the original program was already installed at that point. They are installed to separate folders, and neither would have a chance of affecting the other programs that don't work.

I have tried re-downloading the broken installer, re-downloading it from a different browser, and restarting the computer multiple times - attempting that installer is now the first thing I do when I log on. I have NOT tried Safe Mode or a system restore. I have only uninstalled one program recently, which I can't remember the name of, but it was a disc editor or something that was causing my CD drive to disappear. I have installed a couple games via Steam since that point, but nothing else that I"m aware of. iTunes also updated a couple hours ago with no problems.

Can anybody help? I'm completely lost, and not being able to install things is getting incredibly annoying. For the record, the programs that HAVE worked so far are War Thunder, World of Tanks test server, and World of Tanks EU server. The programs that HAVE NOT worked are World of Tanks NA server, XnView, TeamViewer, and ProcessMonitor.

I'm running Windows 8.1 on a Toshiba Satellite P55-A with an i5 processor. Please let me know if you can help. I've got nothing.

UPDATE: I tried to delete the World of Tanks NA installer, but I got an error message saying that it's still open (in itself, no less). I ran it earlier, but I've already ended the process. About to try restarting to see if the problem persists.
14 answers Last reply
More about exe installer files run computer
  1. UPDATE: problem is solved, though I'm not sure why. Still, if it ain't broke, don't fix it.
  2. Do you have any idea what the cause was as my windows has just started doing literally the exact same thing. Old exe's run fine new ones don't but show in task manager and are using 0.1Mb of ram.
  3. hauntu4ever said:
    UPDATE: problem is solved, though I'm not sure why. Still, if it ain't broke, don't fix it.


    Do you remember what you had done?
  4. Right click the installer then click properties go into the security tab and make sure it has all permissions except special permissions hope i could help :D
  5. I just did a system restore and that fixed it for me.
  6. This is what I found out personally when I was looking for a solution on my own without any good enough help on google :(

    I have Windows 7. (just for your information)

    1. Right click your any installation setup .exe file that ain't opening / running. Click Properties.

    2. At bottom in SECURITY where it says "This file came from another computer and might be blocked to help protect this computer". - Click UNBLOCK, and click APPLY.

    3. That's all, ENJOY guys and leave comments if it helped you too :D
  7. TheBigFluffyDoge said:
    Do you have any idea what the cause was as my windows has just started doing literally the exact same thing. Old exe's run fine new ones don't but show in task manager and are using 0.1Mb of ram.


    I also got the same problem, pls someone help, i'm a developer and in my case it is a disaster when you can't even debug your own project files or setup files.
  8. I'm having the exact same problem, but on Windows 10. Sometimes they work, most of the time they don't.

    The 'security' options are unavailable, given that the setup.exe files are always on a disc.

    Can anybody please help?
  9. ankitnahar007 said:
    This is what I found out personally when I was looking for a solution on my own without any good enough help on google :(

    I have Windows 7. (just for your information)

    1. Right click your any installation setup .exe file that ain't opening / running. Click Properties.

    2. At bottom in SECURITY where it says "This file came from another computer and might be blocked to help protect this computer". - Click UNBLOCK, and click APPLY.

    3. That's all, ENJOY guys and leave comments if it helped you too :D


    Yah, this was driving me nutz on my Vista Home Premium box. After changing the security settings in properties, no more problems. Thanks!
  10. I've got this problem, windows 10. Any one got a windows 10 solution?
  11. ankitnahar007 said:
    This is what I found out personally when I was looking for a solution on my own without any good enough help on google :(

    I have Windows 7. (just for your information)

    1. Right click your any installation setup .exe file that ain't opening / running. Click Properties.

    2. At bottom in SECURITY where it says "This file came from another computer and might be blocked to help protect this computer". - Click UNBLOCK, and click APPLY.

    3. That's all, ENJOY guys and leave comments if it helped you too :D



    Bro, I just wanted to thank you. This worked. Sir, I salute you!
    I am running Windows Vista Basic
  12. The above solution worked for me but the installation seems to hang mid way through and won't progress further. Any solution?
  13. It was a compatibility issue for me. I was unable to open a setup .exe file. How I fixed it:

    1. Right-click on the file, then properties.

    2. Go to compatibility and tick the 'Run this program in compatibility mode' choosing the windows that you have.

    3. Just in case I ticked run as administrator.

    Worked for me.
Ask a new question

Read More

Installer Task Manager Windows 8