Sign in with
Sign up | Sign in
Your question
Solved

Galaxy S4 Ext. SD Card Battery Drain?

Last response: in Cell Phones & Smartphones
Share
April 1, 2014 7:14:56 AM

Hi everyone,

I've been running into the strangest issue lately. I've been using a SanDisk Ultra 32GB micro-SDHC I in my Galaxy S4. Since last week I would get the "SD card has been removed unexpectedly" (or something similar) notification. Usually this would solve itself, the SD card would be recognised again and no problem. Couple of days ago I noticed my phone was dead in my pocket, no battery left whatsoever, even though I charged it that morning. Charged it up again, monitored the battery usage a bit. First two hours were not bad (a bit more usage than usual) and then wham it drained completely.

So I took out the SD card to see if the SD card notifications and the battery issue were connected. My phone survived the night, woke up with like 87% charge. Read some forums about the SD card issue. Found out the connction can be a bit shifty and a dumb solution is to just put some paper in there to push the SD card to the connectors. Tried it. It worked great, that is, no more SD card disconnect notifications. But 10 minutes later my 87% battery was gone.

What is going on??? Will now try to format my SD card and put it back in but decided to post this message here in advance, maybe someone has a clue?

Cheers.

Best solution

April 5, 2014 7:44:48 AM

Try a standard speed card instead of ultra speed, and/or buy a different brand.
Ultra speed cards are unnecessary anyhow for a mobycam.

It's just a hunch nothing more, I'm curious to know if or which of those two options fixes the problem.
Share
April 5, 2014 9:44:52 AM

Yeah after using the phone with no SD for a while I found out the problems were not related after all. Received a new battery today and hope this fixes the issue. However....

During this whole thing I formatted the SD card to FAT32 on my laptop. Now with the new battery I was curious to see how the SD card would do. Put back some of my files on it and popped it in. Got the "empy card or unsupported file format" notification. Considering I had all my files backed up anyway I chose to re-format while in the phone. The next message I got was "SD card can now be removed safely" thought it was weird. Took it out and put it back in again. The "empy card or unsupported file format" notification showed again...:pfff: 

Now when I put the card into my laptop it does not show (the "plink"sound plays but then nothing...) so no acces on the phone or laptop, though they both seem to notice something is in there. I'm really not much of an expert on this so... any advice?

cheers
m
0
l
April 17, 2014 3:19:35 AM

Its possible that the SD is faulty which is what it sounds like and there is a tiny short happening every now again.

I would have said that is was the phone but since you plugged it into your computer and it was still acting up I'm pretty sure its the SD card its self.

Try cleaning the copper connection on the SD card and see if that doesn't help the issues, their may be a piece of lint stuck causing it to short.
m
0
l
!