Sign in with
Sign up | Sign in
Your question

My computers video and audio constanly skip and lag after I installed my graphics card and psu. Even when I'm not playing game

Last response: in Graphics & Displays
Share
April 3, 2014 5:31:27 PM

I installed a graphics card and psu in my computer about a couple of months ago. Ever since then, the audio and the video for EVERYTHING ( not just games ) has been awful. It skips frames and the audio makes crackling noises every time it skips. I could just be sitting at there doing nothing and it will skip. I don't know what to do. I called the company that made my graphics card and talked on the phone for close to an hour. All of my drivers are up to date, and there is nothing running in the background. I have tried about everything. Every article I read online either isn't very helpful, or doesn't even explain the issues I've been having.The graphics card I have is an NVIDIA GeForce GTX 660, and the powersupply unit I bought with it is a Thermaltake TR2 600W. I don't know what to do. I am a huge gamer, and I can't really do much of anything with the constant lagging and skipping and such. Any help would be greatly appreciated. I thank anyone who will try to help me out.

More about : computers video audio constanly skip lag installed graphics card psu playing game

a c 114 U Graphics card
April 4, 2014 5:29:14 AM

What cable are you using? HDMI, DVI try using another slot or another cable see it helps and see if the connections are properly placed.
m
0
l
!