Front USB 3.0 ports won't work with USB 3.0 external HDD

Hi Guys,

I tried every solution I found on the Internet, but none of them worked, so I thought I'd ask here :). There are two scenarios regarding to this problem:
1. The USB 3.0 driver is installed: when I connect the HDD to one of the front ports a pop up says that it needs to be formatted, if I connect to one of the back ports it works fine. USB 2.0 devices work fine in the front USB 3.0 ports.
2. The driver is not installed: the external HDD work with the front ports, but of course with lower speed.
My motherboard is an Asrock H87 Pro4 and the case is a Corsair 300R. I'm running Windows 7 64 bit. The HDD is a WD My Passport Essential SE 1TB and this is my only USB 3.0 device, so I can't try it out with other devices, but it should't be the HDD's fault as it works in the back ports and with other computers USB 3.0 ports.

Thanks for any suggestion!
4 answers Last reply
More about front usb ports work usb external hdd
  1. It could be a driver issue.

    You didn't say which Windows version, but only Windows 8 supports USB 3.0 natively, so you have to add that support by means of a USB 3.0 driver from (in your case) the motherboard manufacturer as per the links below (assuming you're running Windows 7):

    For the ASRock H87 Pro4:

    "Intel USB 3.0 driver ver:2.5.0.19"

    Windows 7 32-bit: http://www.asrock.com/mb/Intel/H87%20Pro4/?cat=Download&os=Win7

    Windows 7 64-bit: http://www.asrock.com/mb/Intel/H87%20Pro4/?cat=Download&os=Win764
  2. Thanks for the reply! Yes I have Windows 7 64-bit and I downloaded the driver from Asrock's site. The problem is when the driver is installed the external HDD with USB 3.0 won't connect via the front USB 3.0 ports.
  3. Yes, stupid advice on my part when I realised you already had installed the driver.
    Not the first time I haven't read a post properly (nor will it be the last I expect)!

    Don't know where to go from there, unless maybe changing it's drive letter in Disk Management does the trick - - not logical I know but worth a try: http://windows.microsoft.com/en-gb/windows/change-add-remove-drive-letter#1TC=windows-7
  4. No problem:) I tried to change the drive letter before though it didn't help. I'm afraid that it's a hardware problem. Maybe the front ports are faulty or the USB connector on the motherboard:??:
Ask a new question

Read More

Storage USB3 Hard Drives External Hard Drive