Blue Yeti Mic does not show up in Control Panel's Sound settings (after working perfectly for a month)

I'm using Windows 7.
I bought a Blue Yeti Microphone about a month ago, and it has been working as it should for the past month. Today, when I plugged it in to do some recording, my computer did not even recognize that something was plugged in. I checked both the Sound settings and the Devices box in the Control Panel, but I could see no sign of the microphone in my computer.

When I plug the mic in, its red light comes on, but the mute light does not blink as normal when I press it.

I tried switching its USB cable for another from one of my devices, but the result was the same--no recognition at all of my microphone's existence, not even a message about a faulty device or driver or an unspecified name. No response from my computer.

I tried it on my friend's computer today, too, and got no response as well.

My USB ports still work; I use a USB mouse with no problem, and I can still plug in and use flash drives without any hitches.

If anyone's got any ideas of what's gone wrong, please help me!! Thank you!
2 answers Last reply
More about blue yeti mic show control panel sound settings working perfectly month
  1. raiskymaiFLY said:
    I'm using Windows 7.
    I bought a Blue Yeti Microphone about a month ago, and it has been working as it should for the past month. Today, when I plugged it in to do some recording, my computer did not even recognize that something was plugged in. I checked both the Sound settings and the Devices box in the Control Panel, but I could see no sign of the microphone in my computer.

    When I plug the mic in, its red light comes on, but the mute light does not blink as normal when I press it.

    I tried switching its USB cable for another from one of my devices, but the result was the same--no recognition at all of my microphone's existence, not even a message about a faulty device or driver or an unspecified name. No response from my computer.

    I tried it on my friend's computer today, too, and got no response as well.

    My USB ports still work; I use a USB mouse with no problem, and I can still plug in and use flash drives without any hitches.

    If anyone's got any ideas of what's gone wrong, please help me!! Thank you!


    Did you manage to find the problem and a fix? As mine has just done the same.. It appears as an unknown device
  2. Mine is doing the same. I am beyond frustrated for a device to work and then just stop after a while
Ask a new question

Read More

Control Panel Windows 7 Microphone Computers USB