Solved

asrock 970extreme3 UCC crash

When i enable the UCC in the bios my pc crashes.
Its fine for a while but when i run a game or 3ds max, Unity etc, after about 15 mins the pc crashes with a blue screen. it seems to happen when the CPU is under load.
It worked fine with the AMD 4300. Only thing i could think is that my power supply is not sufficient.

PC pecs.

Asrock 970 Extreme3 Motherboard
AMD 8350 CPU
PowerColor 7870 Myst Edition GPU
8GB ddr3 1333
Antec 550w PSU
Corsair H100i Water cooling
500GB 5200rmp HDD
5 answers Last reply Best Answer
More about asrock 970extreme3 ucc crash
  1. oh really, never even considered that. i just assumed if its the same socket it would be ok. does that not mean the cpu should not work at all
    does that mean im not getting the full advantage of my cpu
  2. Using an unsupported processor is more of an experiment on your part. Damage to the motherboard may not be covered under your warranty.
  3. Best answer
    That board can't handle the FX8320 or 8350 , due to it's poor thermal and power design.

    Therefore not supported.
  4. Ok thank you for all the awnsers. i asked this on other forums and no one had any idea.
    i think i will change my mother than, hopefully i will get the full power from my cpu becuase it doesnt seem to be performing great. my 4300 cpu preformed the same as the 8350
Ask a new question

Read More

BIOS Crash ASrock Motherboards