Sign in with
Sign up | Sign in
Your question
Solved

Asus Rampage IV Extreme not booting up!

Last response: in Motherboards
Share
April 22, 2014 4:03:32 PM

my specs:
CPU: Intel Core i7-4930K 3.4GHz 6-Core Processor
CPU Cooler: Corsair H100i 77.0 CFM Liquid CPU Cooler
Motherboard: Asus Rampage IV Extreme EATX LGA2011 Motherboard
Memory: G.Skill Ripjaws Z Series 32GB (4 x 8GB) DDR3-2133 CL11-11-11-1 1.5v
Storage: Samsung 840 Pro Series 256GB 2.5" Solid State Disk
Video Card: EVGA GeForce GTX 780 Ti 3GB Video Card
Case: Corsair 750D ATX Full Tower Case
Power Supply: Corsair Professional 750W 80+ Gold Certified Semi-Modular ATX Power Supply

Hey guys this is my first post and first time puttin a computer together. I decided to go with a high end rig for the first time and ive been runnin into a problem that i just cant find an solution for. Ive searched around and the solution seems to be in my bios.. I need to update it for the processor. Ive done the USB Flashback step by step and whenever i try to do it, the ROG button flashes for about 6 seconds and stops. Nothing chances and i still get no signal on my display. I heard its supposed to update for about 2-3 mins but 6 secs seems off. The LED on the top right corner of the Mobo shows code 00. Ive almost given up on tryin to fix it myself and send it to someone that knows exactly what theyre doin but im willin to try anythin at this point.
Thanks.

Best solution

a c 174 V Motherboard
April 22, 2014 7:47:15 PM

Resy said:
my specs:
CPU: Intel Core i7-4930K 3.4GHz 6-Core Processor
CPU Cooler: Corsair H100i 77.0 CFM Liquid CPU Cooler
Motherboard: Asus Rampage IV Extreme EATX LGA2011 Motherboard
Memory: G.Skill Ripjaws Z Series 32GB (4 x 8GB) DDR3-2133 CL11-11-11-1 1.5v
Storage: Samsung 840 Pro Series 256GB 2.5" Solid State Disk
Video Card: EVGA GeForce GTX 780 Ti 3GB Video Card
Case: Corsair 750D ATX Full Tower Case
Power Supply: Corsair Professional 750W 80+ Gold Certified Semi-Modular ATX Power Supply

Hey guys this is my first post and first time puttin a computer together. I decided to go with a high end rig for the first time and ive been runnin into a problem that i just cant find an solution for. Ive searched around and the solution seems to be in my bios.. I need to update it for the processor. Ive done the USB Flashback step by step and whenever i try to do it, the ROG button flashes for about 6 seconds and stops. Nothing chances and i still get no signal on my display. I heard its supposed to update for about 2-3 mins but 6 secs seems off. The LED on the top right corner of the Mobo shows code 00. Ive almost given up on tryin to fix it myself and send it to someone that knows exactly what theyre doin but im willin to try anythin at this point.
Thanks.


The USB flashback upgrade can be completed without the CPU installed in the socket at all. That's probably the best method to pursue for an unsupported CPU. You must also make sure that your USB stick is formatted to the correct file system and that the firmware image is named correctly.
Share
!