Sign in with
Sign up | Sign in
Your question
Solved

Why is my Battlefield 4 so slow?

Last response: in Video Games
Share
April 23, 2014 12:52:24 PM

I recently bought Battlefield 4 and started playing but found it very hard to play with an fps of around 15-20, despite nothing but good reviews on the gtx765m. My laptop has this as a GPU and an i5-4200m for a CPU. Also, a 64bit OS.

Can someone help me with trying to fix this or to just get a decent framerate on better graphics? Thanks.

More about : battlefield slow

April 23, 2014 12:58:12 PM

scottbowsher said:
I recently bought Battlefield 4 and started playing but found it very hard to play with an fps of around 15-20, despite nothing but good reviews on the gtx765m. My laptop has this as a GPU and an i5-4200m for a CPU. Also, a 64bit OS.

Can someone help me with trying to fix this or to just get a decent framerate on better graphics? Thanks.


Hello, can I ask what settings your running at and what resolution? Also, do you have updated drivers?

m
0
l
Related resources
April 23, 2014 1:09:10 PM

I am running it at 1920*1080 60.01z, and at medium settings. I am pretty sure my drivers are updated since I got this laptop in early February.
m
0
l

Best solution

April 23, 2014 1:59:15 PM

scottbowsher said:
I am running it at 1920*1080 60.01z, and at medium settings. I am pretty sure my drivers are updated since I got this laptop in early February.


Hmm, like the answer above the benchmarks are showing around 30fps, it's wired that your getting less, it may be because you have a weaker CPU or that they are testing it in less intense situations, try googling round a bit more, sorry I can't help more but I honestly don't know why. If you can't find a solution try reducing the resolution to 1600 x 900 or lowing the settings, also make sure your resolution scaling is on 100%, that's something you could also try lowering to increase performance. Hopefully someone else will know a solution.

Good luck!
Share
April 25, 2014 9:36:07 AM

Turns out I hadn't downloaded the correct drivers, and now it runs as smooth as silk on ultra. Thanks for the advice!
m
0
l
!