can't get my new graphics card to work!! black screen after windows loads...

Hi! I just got an Asus HD7970, but after I installed it to my PC, I see that windows boots up, but then a black screen follows and I can't see anything anymore.

I already downloaded the latest AMD driver before... The only way I could get it to work was in safe mode, but in a horrible resolution.

My specs:

Asus P8Z77-V PRO
i5-3570k
G skill Ares 16gb 1866Mhz
Be quiet pure power l8 630W
I'm running windows 8.1 pro.


Does anyone have a fix for this? I searched every single thread but I couldn't find a solution that worked for me.

Thanks in advance!
5 answers Last reply
More about graphics card work black screen windows loads
  1. Did you uninstall your previous drivers?
  2. You need to have removed the previous video card's drivers first. You may be able to use something like CCleaner in Safe Mode to do it, or just re-install your old card so you can uninstall it properly.
  3. mouse24 said:
    Did you uninstall your previous drivers?


    I didn't have a graphics card before... I was using the intel HD4000. do I uninstall that through device manager?
  4. When you installed the new graphics card, did you move your monitor's cable to it? Otherwise, I believe you'd need to load the LucidLogix MVP drivers that come with your board.
  5. Found the solution!! I just had to disable the Intel hd4000... I was just about to uninstall when I thought I could just try disabling it hahaha! Thanks guys!
Ask a new question

Read More

Windows GPUs Graphics Cards Windows 8 Graphics