Sign in with
Sign up | Sign in
Your question
Solved

FX8320 on Asrock 970 Extreme3 R2 won't POST, blank screen

Last response: in CPUs
Share
April 24, 2014 7:36:15 PM

970 Extreme 3 R2 FX8320 1x Corsair RAM Powercolor r9 290

I bought the processor off ebay to replace a Sempron 145 and originally installed it with an hyper212 cooler without fan (because i lost the fan brackets). After about 1 hour win8 crashed with BSD. I assumed it was heat because the processor was at 70 just before the crash. I turned off the computer right away. When I tried to turn it on the next day, there was no POST.

I got a fan for the Hyper212. Still didn't work. I put the Sempron back in and it booted up fine.
Putting the 8320 back in with new thermal paste and heatsink again still doesn't work.

Many people quickly say the CPU is fried. But after a lot of research it seems that these CPUs have a safety mechanism that shut themselves off. Just wondering if anyone has any ideas?

Best solution

a c 983 à CPUs
a c 411 À AMD
April 24, 2014 7:50:08 PM

I would say It's a defective CPU.

Get your money back.
Share
May 22, 2014 4:47:31 PM

anixon said:
970 Extreme 3 R2 FX8320 1x Corsair RAM Powercolor r9 290

I bought the processor off ebay to replace a Sempron 145 and originally installed it with an hyper212 cooler without fan (because i lost the fan brackets). After about 1 hour win8 crashed with BSD. I assumed it was heat because the processor was at 70 just before the crash. I turned off the computer right away. When I tried to turn it on the next day, there was no POST.

I got a fan for the Hyper212. Still didn't work. I put the Sempron back in and it booted up fine.
Putting the 8320 back in with new thermal paste and heatsink again still doesn't work.

Many people quickly say the CPU is fried. But after a lot of research it seems that these CPUs have a safety mechanism that shut themselves off. Just wondering if anyone has any ideas?


unfortunately, AMD cpus, dont have thermal cut out. intel cpus will freeze and shut off. amd's will not, unfortunately, it sounds to me like a fried cpu or possibly defective. rma if you can
m
0
l
!