Sign-in / Sign-up
Your question
Solved

System built with some second hand parts... Problems with AHCI and video performance

Tags:
  • Sabertooth
  • Intel i7
  • Framerate
  • Systems
  • Graphics
  • Performance
Last response: in Systems
April 25, 2014 10:23:49 AM

I'm just looking for a solution to my problem. A month ago I purchased a bunch of older system components from a co-worker and purchased a few things to fill in the missing hardware in the system. Here are the specs:

Case: Thermaltake Armor Plus
PSU: Thermaltake M850
Mobo: Asus Sabertooth x58
CPU: i7 950 not oc'd at the moment
CPU cooling: Corsair Hyrdo Series H100
Mem: G-skill F3-12800CL9t2 (6x 2gb sticks)
Gfx: 2x HIS R7 260x in Crossfire
Storage: Seagate Barracuda ST1000dm003 1tb 64mb cache SATA III

I am trying to figure some things out, mainly with memory and drive settings in BIOS and windows. I'm running windows 7 ultimate. My problem is, that originally I had issues installing windows on the drive, once I got to the drive selection screen and I tried to install to the drive it would give an error about not being able to create the partition or find a partition suitable for install but the drive was visible in the selection box. I know usually when you format a drive at this screen that it will separate 100MB for system and the rest for the OS install but it wasn't doing this. So, to solve the problem I moved the drive to the 2nd SATA port on my Marvell 9128 controller (Only two ports on this board), restarted the installation and opted to install the AHCI/RAID drivers before I formatted and attempted to install Win7. It worked, and I thought nothing of it, but now when I'm in windows it's a bit sluggish, I've noticed that it takes just as long as it did to do everyday tasks as it did with my SATA II drive I was using in the system previously. I've also noticed that when I'm running games like Titanfall, BF4 and others that load times are long and I've noticed that I get frame drops when I look around in game. Usually only when I change directions, which tells me there is a bottleneck somewhere causing textures and other geometry to take longer to load than usual. I've looked in the BIOS and my Marvell SATA III controller is set to AHCI mode and my memory is set at 1600 where it should be. In windows, the drive shows up under device manager as a SCSI device, my SATA II controller shows up in device manager, but the Marvell controller is not listed. Tonight when I get home I'm going to check regedit to make sure windows was installed and is running in AHCI mode.

The kicker is, before I had the new drive and the new memory I was running two 4gb Kingston modules in dual channel and an older 160gb seagate drive that was SATA II and my performance was better. You'd expect some better performance with the new Barracuda 1tb with 64mb cache on the SATA III controller with 12gb of memory, but in my case I think there is a problem. I need help with this issue, and any input is appreciated!!

More about : system built hand parts problems ahci video performance

Best solution

April 25, 2014 1:55:28 PM

Connect the boot drive to SATA port 0 . Or which ever has the lowest drive number of the intel driven SATA ports .
There should be no need to install ACHI or SATA drivers first

Set AHCI in BIOS

Install windows , then the mb drivers , then the graphics driver
Share