ASUS R7 260X wont boot past logo after restart unless i power it off

I have a problem with my computer:

System:

CPU: FX 8320
Motherboard : GA-990FXA-UD3 Rev 3.
RAM: 16 gigs of Corsair Vengeance RAM
Power Supply: Ultra LSP 750 Watt Rev 2
Video Card: ASUS R7 260X (Overclocked Edition)

Did a fresh install of Windows 7 (Legit Copy) updated my bios Firmware to the latest one available on the Gigabyte Web Site.

Computer runs fine with no Drivers installed with Windows 7. I can do a restart and it loads up fine. As soon as I install the latest drivers from the ATI web site It will no longer boot past the windows logo. The only way I can boot it is to shut down the computer and turn it back on and when I do that it runs fine I can play games etc.. It just does not like a restart.

I replaced the card with the same model and same problem. Any suggestions?

And I did try the drivers that came with the card with the same result as well.

One more thing: This computer worked flawlesly before i swaped out the Power Supply, CPU and Graphics Card :)
2 answers Last reply
More about asus 260x wont boot past logo restart power
  1. What drivers came with the card? 13.2? (think thats what came with mine) they worked fine for me.
    All the drivers up to 14.2 worked fine but upon installation and restart of anything newer,i cant get passed the logo loading screen. It just loads forever untill i shut it down hard and then do a Repair Restart and subsequent system restore.

    Try 14.2 or 14.1 BETAS?
  2. Ill have to check what driver version was included on disk. I just swapped my video card with an Ice Q 5770 and it works fine with that card in it. Im puzzled
Ask a new question

Read More

Power Boot Motherboards Graphics Asus New Build