Solved Closed

USB Ports giving power but not detecting devices.

Ok so I had to replace my hdd after my old one gave out, when I reinstalled everything the only usb port to work on my laptop was the eSATA port I have a Dell inspiron m5110, which is dell inspiron m511r on their website and have downloaded every driver possible.

I'm not quite sure what to do but here's my device manager and what has yellow triangles next to em.
http://i59.tinypic.com/2i8y5ua.png
13 answers Last reply Best Answer
More about usb ports giving power detecting devices
  1. Hi zach2424
    you will have to install the drivers for your usb controller
    if you can tell me what version of windows you are using and 32/64bit i will give you a link
  2. Thanks I'll tell you how it works out.
  3. hope it all goes well for you
  4. After I download it like every other driver, it extracts to dell drivers folder, unlike the other driver installations though when I click setup it loads for a second and then nothing pops up, I've tried to redownload the file directly from dell as well to no avail.
  5. hmmm i will investigate this further , i don't understand why it failed to install , if you go into the device manager and try to install the driver from a specific location does it find any of the drivers you have ?
  6. Not sure what you mean by that.
  7. Could it have anything to do with the drivers being for N5110 and my computer being M5110?
  8. when you go into your device manager and you see those yellow question marks you should be able to right click on them and update driver software
    you can tell it to search in a specific location example cd rom if you have a drivers disc and it will automaticaly look in that location and pick up those drivers and install them or you can make it scan your whole computer to find them
  9. Yeah just says couldn't be updated.
  10. Best answer
    ok i may have found something , you may be right the driver link i gave you before could have been wrong
    after a painstaking search i think i may have found the right drivers
    http://www.driverscape.com/manufacturers/dell/laptops-desktops/inspiron-m5110/2037
    scroll down and download all the usb device drivers and try to install them
  11. That worked the exact one was this link http://www.driverscape.com/download/amd-usb-3.0-host-controller and the file size 60.28mb one incase anyone else needs to know thanks for all your help :D
  12. glad it worked , hope it all goes well for you , we got there in the end
    pick as the solution if i was helpfull thanx
    all the best
Ask a new question

Read More

Dell Inspiron USB Windows 7