Pleae helpe me Gigabtye 970A-UD3 Mic not Working

My mic is being detected everytime I put it in. I've been trying to get this to work for days, I recently reset my bios. Downloaded all the drivers, mic didn't work. Downloaded Realtek doesn't work. Downloaded the specific AVI audio driver from the manual finally got the AVI HD Deck to come on messed with everything and still not working.I went in device manager and uninstalled all the audio drivers then reinstalled them still no sound coming out of my mic. PLEASE HELP PLEASE
7 answers Last reply
More about pleae helpe gigabtye 970a ud3 mic working
  1. I gather you left the word NOT out of the first sentence.

    What make and model mic?
  2. Sometimes, it is a connector problem. Maybe it's time to see a technician for this... Can you use your mic header (in the motherboard)? So you could isolate if this is really a connector problem..
  3. It's just a turtlebeach headset, it was working fine for months, but I flashed my gpu, then went back to stock, and reset-ted my bios. I don't know how to use the mic header i'm not to familiar with that.
  4. You'd need a jumper lead. If your not technical, maybe take it to a pc shop.

    Have you tested the headset on other pcs? It might be the headset
  5. I have another pc ill test it on. I shouldn't be broken though I used it 2 days ago nothing happened to it ill report back.
  6. It's working on my other computer.
  7. Steve Ring said:
    It's working on my other computer.

    Are you connecting the mic to the front or the back of your PC? If front, is the connector configured as HD or AC97 in the BIOS? If HD, switch it to AC97 and the mic should work.

    You should have documented your settings before resetting them.
Ask a new question

Read More

BIOS Drivers AVI Motherboards