Solved

Asus P6X58D Premium not detecting newly installed RAM properly.

So i'm working on a computer with an Asus P6X58D Premium mobo and (previously) 6Gb of RAM (Corsair CM3X2G1600C8D, 3x2gb, triple channel). I had some extra ram laying around, specifically 6Gb (Mushkin 998691, 3x2gb, triple channel). Now i thought it would be easy to put those in the remaining memory sockets and double the memory. Not so much.

No matter what i do i cannot get the bios to recognize the system has more than 6Gb of RAM. Firstly, just after placing them in nothing at all changes. The memory isn't seen by the BIOS. However, upon booting into windows and launching CPU-Z, it detects all of the ram in the SPD tab. Slots 1, 3, 5 it detects the proper corsair sticks, and in 2, 4, 6 it detects the proper Mushkin sticks, and says the total memory should be 12288Mb. But it isn't. It also says the system is now running in dual channel mode instead of triple.

What i tried:
Manually adjusting all the frequency and voltage values in the bios. This ended with some wild results. Most of the time the system would detect only 4088Mb of RAM, once it detected 8176Mb, and sometimes the proper 6Gb. I found a post here on the forums with specific values to try, however they did not work and resulted in the readings above. Finally i just reset everything to auto and it seems to stick on 6Gb consistantly, but in dual channel, not the correct triple, and certainly not the full 12Gb.

So that's about it. I don't know what to do really. Anyone have any ideas what i can try?
11 answers Last reply Best Answer
More about asus p6x58d premium detecting newly installed ram properly
  1. Have you raised the QPI/VTT voltage (it's the MC (memory controller)s voltage? take it up about + 0.15 from the current setting, also raise the DRAM voltage + 0.05
  2. Mixing different manufacturer's ram is never a good idea. Almost always there will be problems. Both kits have different timings and voltages.
  3. I have tried upping the voltage, i tried up to 1.35 for the qpi/vtt and 1.64 for the dram.

    I realize it's not optimal to mix brands, but it's what i've got on hand for someone that cannot afford anything new, so it's one of those things where i need to make it work.
  4. Might try with those settings and change freq/timings to 1333 9-9-9-27
  5. I did try setting the freq to 1066 and 1333, but i didn't try 9-9-9-27, just 9-9-9-24. I'll report back in a bit and see if that changes anything.

    What is the fact that it's switched to dual vs. triple channel a symptom of though?
  6. Sadly 1333 @ 9-9-9-27 did not help
  7. Best answer
    If reading dual, it might not be fully reading a stick, might try pulling them and cleaning the contacts (rubbing alcohol and a foam swab are best - erasers can leave residue and cotton swabs often leave fibers, and alternative to the foam swabs (like makeup swabs) is lint free cloth or even a paper towel and if any canned compressed air, blow out the slots
  8. Ok i will try that. Althought just to be clear, CPU-Z clearly sees all of the memory sticks correctly once i'm in windows, the bios, however, does not.
  9. Have latest BIOS ?
  10. Uh bios is revision 904 from 2010 iirc.

    I tried cleaning and reseating, no joy. I also tried pressing the Asus MemOK button and got some... interesting results. 3 out of 4 times it detected 6Gb of ram and set everything to auto; once, though, it detected 8Gb ram and wanted to set the VRAM to (a dangerous?) 1.7v. I also tried QPI/VTT up to 1.45v.
  11. Sounds like the sticks just don't want to play nice together, which happens, I wouldn't take the voltages any higher myself :(
Ask a new question

Read More

Computers Triple Channel RAM Motherboards Memory Asus