Sign in with
Sign up | Sign in
Your question
Solved

Asus P8P67 Pro quit on me-- motherboard or CPU?

Last response: in Motherboards
Share
April 29, 2014 12:34:22 AM

I have an Asus P8P67 Pro 3.1 motherboard with an Intel i5-2500k. I bought the pair used in December, so I have no idea how they were treated before that.

The 2500 has been overclocked since I had it, but it has proven to be a poor overclocker compared to the norm for the Sandy CPUs. The highest speed I could get it fully stable at with 1.36 volts was an unimpressive 4.4 ghz (with CM Hyper 212+). I don't know whether I just lost the silicon lottery, or if the previous owner beat the thing to death and degraded it.

I was using the puter today, and had just started a game, when the monitor went black and told me it was going into power saving mode. The power light on the PC was off... the power button did not respond. Cycling the PSU rocker switch and then trying to turn it on did not change anything. The only one of the Asus motherboard LEDs that came on for more than a fraction of a second was the power LED, which comes on and remains on whenever the PSU is connected and turned on. On the first start after a power cycle, the CPU_LED light flashed for a split second before going off and remaining off.

I opened the case and removed the components and wires, one by one, trying to see if one might have been causing it (turning off the PSU and allowing the capacitor to discharge each time before turning it back on). The only change at all came when I unplugged the 8 pin EPS connector... when I did that, hitting the power button caused the fans (connected to motherboard headers) to spin up and stay on, and the motherboard CPU_LED light came on, but nothing else happened.

I even tried removing the memory to see if I could get it to throw me a beep code (I plugged the pc speaker back in, obviously). It did not change anything. No beeps.

I tried another PSU-- same results. I took the motherboard out of the case to make sure there was nothing like a screw wedged between the board and the back plate... out of the case with only the memory, CPU/HSF, the PC speaker, the power switch lead, and the PSU connections (the big one and the 8 pin), it still did the same as above.

I have no other Intel CPUs or motherboards to test it by process of elimination. I know CPUs seldom fail unless someone does something to them (and I have not changed anything with the CPU lately), so my guess is motherboard, but the fact that it always needed a lot of voltage to get it stable with a mediocre O/C makes me wonder if it had degraded and had given up on me.

Even when I had my perfectly working GTX 760 installed, the VGA light never came on either. I am using the 760 right now in an older AMD motherboard, so I do know for sure it works. Clearing the CMOS did not change anything.

Anyone have any ideas?

Thanks!
Frank


Best solution

a b Ĉ ASUS
a c 95 V Motherboard
a c 106 à CPUs
April 29, 2014 1:30:28 AM

See if you can contact the original selling, get a purchase date and then check with Asus for an RMA.
Share
!