Sign in with
Sign up | Sign in
Your question
Solved

Everything on my laptop seems to lag. Especially browsers.

Last response: in Windows 7
Share
April 30, 2014 3:07:54 AM

I have a brand new Lenovo z510 (Win 7 Ultimate x64, Intel i3-4000M 2,4 GHz, 8GB RAM and Geforce 740 M (2GB).

Everytime I surf with Chrome, youtube videos and web pages as a whole lag a little bit until they fully load. The whole operations of clicking somewhere or scrolling also lag a little bit sometimes. Also system operations seems to work a little bit...slow. My laptop should "think" slightly faster than it does. With these characteristics my laptop shouldn't act slow, at least not for surfing the Internet. I have no idea what is happening.

I have tried re-installing Windows, deactivating/changing Antivirus software, updating video drivers, updating all other laptop drivers to the latest, updating flash player, removing extensions (I only use Adblocker), cleaning the browsing data and cache, defragmenting hard drives and making my laptop on "high performance" mode. Nothing seems to work. The lagging problem occurs when using Firefox as well.

Can you please recommend me any solution to this issue? I can live with the system doing things slower, but lagging when I browse or watch videos on YouTube..this is hell. I hope that you can help me. Thank you very much.

More about : laptop lag browsers

Best solution

April 30, 2014 4:19:32 AM

Use latest version of advanced system care, perform full system scan and click allow fix problems.
Share
April 30, 2014 10:06:43 AM

Thank you very much! It now works a little bit better, although it doesn't take much time before it slows down again and I have to re-apply the program scan again.
m
0
l
!