Catalyst Control Center doesn't open after 14.4 driver update

Hi, like in the title, I updated my Radeon HD 7670M driver and it works very good :) but CCC no longer works. I can see in task manager that a process starts and go off in a second. Tried different versions of CCC or drivers, used CCleaner and nothing works. All games work, everything is fine but i can't open CCC to switch graphic cards. Maybe someone can tell me proper CCC version? I tried 13.1, 13.4, 13.9 and 14.4 versions of drivers but it's all the same. Sorry for my bad english, I hope you'll answer me soon :)
2 answers Last reply
More about catalyst control center open driver update
  1. you are going to have to directly uninstall CCC and re-install your previous version. If you can't uninstall, get the driver and force a downgrade through the AMD CCC, the current driver may not work, so best not to install it again for a while, wait for the next version.

    If you have no chance, delete everything to do with the CCC's existence (not the card driver itself), which you'll find in program files/X86, then re-install.
  2. i've done this a couple times, didn't work... i don't want to install other card drivers because on the other hand i had troubles with them not CCC, most of my games didn't work on older drivers
Ask a new question

Read More

Catalyst Graphics