Sign in with
Sign up | Sign in
Your question

Need help with PC issue-powering on but not booting

Last response: in Systems
Share
April 30, 2014 8:38:42 AM

Hello everyone, I'm new to this forum so hope this in the right place/format. I'm having a rather frustrating PC issue and need some help, any of which is appreciated.

A few weeks ago I was playing on my PC when the screen suddenly went black. The PC seemed to be working okay apart from that as I told my friends on Teamspeak that I needed to restart my PC. Since then the PC powers on but refuses to boot. I can't get any POST messages and nothing comes on the display. Here is what I have done so far:

1: Bought a new PSU, issue is not resolved.
2: Tried booting with different RAM, no luck.
3: Tried an old GPU of mine I had
4: Trying removing my sound card

So far, no luck at all. It seems to be a CPU or motherboard issue to me but I did a test of trying to boot with no RAM installed and got beeping from my motherboard, which I've been told means it's okay. So I'm really not sure where to proceed from here. Any advice/troubleshooting methods whatsoever is really appreciated.

If you need more detail or have any questions please ask and I will answer them, thank you.

More about : issue powering booting

a b U Graphics card
a b ) Power supply
April 30, 2014 10:40:21 AM

full specs and were any cheap PSUs used?
m
0
l
April 30, 2014 12:18:11 PM

ganon11000 said:
full specs and were any cheap PSUs used?


Okay, here are the specs:

CPU: I5 760 2.8ghz
RAM: 8GB DDR3 1600mhz
Mobo: Asus p7h55-m/usb3
PSU: CoolerMaster Extreme Power Plus 550w (not the best but not a no brand budget thing either) My new PSU is a Corsair CX750
GPU: XFX HD7870

The CPU and Mobo were a bit over the hill, that's for sure.
m
0
l
Related resources
a b U Graphics card
a b ) Power supply
April 30, 2014 1:19:22 PM

try booting on Intel graphics with 1 stick of ram and nothing else plugged in
m
0
l
April 30, 2014 1:27:16 PM

ganon11000 said:
try booting on Intel graphics with 1 stick of ram and nothing else plugged in


Okay man, will try that and report back tomorrow, thanks for the advice.
m
0
l
May 3, 2014 5:03:01 AM

Okay, I tried what you suggested and still no luck. No response, nothing.

Any other ideas? Help is hugely appreciated.
m
0
l
a b U Graphics card
a b ) Power supply
May 3, 2014 7:00:47 AM

if that didn't work I bet the motherboard is dead or, in and extremely rare case, the CPU died.
m
0
l
!