Sign in with
Sign up | Sign in
Your question
Solved

White screen new GPU

Last response: in Graphics & Displays
Share
April 30, 2014 2:57:13 PM

Hi all.

I have recently upgraded my graphics card to a hd 6870. During a stress test to check temperatures the screen went grey with lines down the screen then white when it got to 81 degrees.
In panic I turned off my pc. But upon turning it back on there is no display after the start up screen. Just wierd boxes and lines.
Any ideas?

More about : white screen gpu

a b U Graphics card
April 30, 2014 3:02:38 PM

How long did you wait to turn it back on again? It may not have had time to cool down.
m
0
l
April 30, 2014 11:51:01 PM

ewok93 said:
How long did you wait to turn it back on again? It may not have had time to cool down.


Turning it on again this morning and the same has happened.
m
0
l
Related resources

Best solution

a b U Graphics card
April 30, 2014 11:58:09 PM

Hmm... that's interesting. Can you RMA or return it?
Share
May 1, 2014 3:43:49 AM

ewok93 said:
How long did you wait to turn it back on again? It may not have had time to cool down.


I tried turning it on again this morning and it displayed the same weird screeen.
m
0
l
a b U Graphics card
May 1, 2014 4:12:33 AM

Yeah, I think it may be broken...
m
0
l
May 1, 2014 4:36:49 AM

ewok93 said:
Yeah, I think it may be broken...


Hmm I posted twice there, my bad.
Are there any troubleshooting steps I can take to find the fault?
m
0
l
a b U Graphics card
May 1, 2014 4:40:48 AM

Look at it and see if there are any blown capacitors. What power supply do you have? I think that may have been the issue.
m
0
l
May 1, 2014 4:56:37 AM

ewok93 said:
Look at it and see if there are any blown capacitors. What power supply do you have? I think that may have been the issue.


Power supply is a brand new corsair cx600m. If it was the psu would the gpu have even worked at the begining, prior to the stress test?

m
0
l
a b U Graphics card
May 1, 2014 4:59:13 AM

Yeah, it's entirely possible for it to work a bit before it has issues, but if you have a 600w I wouldn't be concerned about that. I think it may just be a DOA card.
m
0
l
!