Sign in with
Sign up | Sign in
Your question

Unable to open Catalyst Control Center. Help!!!

Last response: in Graphics & Displays
Share
May 1, 2014 8:39:30 AM

I recently cleaned my radiator (H100) and after i started up my PC everything was at a lower resolution. I tried opening Catalyst Control Center but I got a error saying "No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware"

After I pressed ok another error came saying "AMD Catalyst Control Center cannot be started. There are currently no settings that can be configured using AMD Catalyst Control Center"

and then I pressed ok. I was using CCC version 13.12 and worked fine till I booted up this time. So I used AMD clean up utility to uninstall everything. And after rebooting I downloaded newest driver from AMD that is 14.4 and installed it without issue. (Running Windows 8.1 64 bit, 2 HD 7970 crossfire). Everything was fine until I restart the PC for the SECOND time because the first restart didn't give any problem. The restart after that, the same problems came back as mentioned in the beginning. The problem can be fixed by going through the same process of reinstalation of driver but problem comes back again after second restart.

Please help :??: 

CPU Core i7 2700k
GPU Two HD 7970s
8 GB RAM
SAbertooth P67 motherboard
May 1, 2014 7:04:33 PM

do you mean you clean the heat sink? if so did you knock the card loose or the power connector to it loose? if so try to make sure its all plug in good. a bad connection could prevent the card from working fully and you would get issues
m
0
l
May 2, 2014 4:10:10 AM

maxwellmelon said:
do you mean you clean the heat sink? if so did you knock the card loose or the power connector to it loose? if so try to make sure its all plug in good. a bad connection could prevent the card from working fully and you would get issues


I did check but if that was the problem how could it work perfectly fine after I reinstaled the driver. I only get those errors after restarting the PC. After that I have to again go through the process of reinstallation and works fine again. Until I restart..

This is what it shows in MSI After Burner
m
0
l
May 3, 2014 12:23:13 PM

Ok so I found out that downgrading driver to 13.9 solves the problem.
or
By Disabling Driver Digital Signature

Open an elevated command prompt and enter the following.
bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS

restart and install latest driver

problem solved
m
0
l
!