Sign in with
Sign up | Sign in
Your question
Solved

Geforce GTX 470 not working after installing drivers

Last response: in Graphics & Displays
Share
May 5, 2014 1:18:57 PM

Geforce GTX 470 on Windows 7 64bit

The graphic card works with generic Windows drivers.

After installing Nvidia drivers the computer boots up, the BIOS is good, the Windows logo appear on the screen, then, instead of going into the desktop, Windows becomes all black. I can hear the audio welcoming sound and but no video.

Everytime I change the drivers with the generic Windows drivers everything works fine. I have tried several versions of the Nvidia drivers and none of them work. All the drivers were uninstalled properly and fully removed by using programs such as Driver Sweeper.

I have tried uninstalling and disabling my Realtek audio (as some other users suggested in other forums), but it didn't help. I tried disabling other devices and nothing worked.

I assume the video card is working properly, since it works without drivers and the problem is only after Windows boots into the desktop.

Any suggestion?

I'll be trying other operating systems as well, then I'll get back with the results.

May 6, 2014 10:57:07 PM

driver version? have you tried using the last one that is working for you?
m
0
l
May 7, 2014 7:01:09 PM

Just to give an update. I have installed the card on another computer with Windows 8.1 and it's working good with the nVidia drivers. It's really weird that it won't work on a more recent computer with Windows 7. This card may be old, but it still rocks. Too bad that is a power drain.
m
0
l
Related resources
May 7, 2014 7:03:00 PM

renz496 said:
driver version? have you tried using the last one that is working for you?


Yes, I have tried those drivers and they are not working. I downloaded and tried all the nVidia final release drivers.
m
0
l

Best solution

May 7, 2014 7:52:14 PM

what version of driver sweeper you are using?
Share
May 8, 2014 8:17:08 AM

renz496 said:
what version of driver sweeper you are using?


3.2.0

m
0
l
!