Sign-in / Sign-up
Your question
Solved

SSD Functional - "Insert Boot Media In Selected Boot Device", Windows 7 No Longer Booting

Tags:
  • Windows 7
  • Storage
  • Hard Drives
  • Boot
  • SSD
Last response: in Storage
May 9, 2014 4:52:10 AM

Hello Everybody,
I tried to start up my computer the other day, but ran into the "insert boot media in selected boot device" problem.

I currently have a Intel 520 120GB SSD as my primary drive.

I did what anybody would do, opened up my PC and checked the connections and checked BIOS, and still nothing, still the same "insert boot media in selected boot device" message. I even tried clearing the CMOS.
Even when I checked for errors from another PC, there were none of those to be found.

I changed the SATA connections, hoping that might work - both the cable and the port, still no luck. I even tried booting it via another computer as the primary drive, as I have had success with that before, but I get the same error message.

I am still able to access the data from another computer, when the drive is plugged in along side another boot drive, but am unable to reach Windows with it.
Normally I wouldn't care, I can access the data, just back it up and start all over again, but I have a encryption key/certificate that I need to access, which I of course didn't backup, fearing somebody may access it.

Is there anything anybody thinks that I could do? I find it odd that there is no errors found, and that I am able to access the data, but it will not boot at all - even to a repair screen.
Any help would be greatly appreciated.

Thank you!

More about : ssd functional insert boot media selected boot device windows longer booting

Best solution

May 9, 2014 4:58:00 AM

It sounds like something has got corrupted with windows... These things can happen- the drive is probably fine.

You can try and use AOMEI to rebuild the boot files on the drive:

http://www.aomeitech.com/aomei-partition-assistant.html

Its a free tool and it might solve you're problem (I'd take a full image of the drive first however- just in case, that way all your data is stored elsewhere).

Share
Related resources