Solved

something wrong with my RAM

So i just finished building my first PC. Something seemed to be wrong with it because it would turn off 3 seconds after turning it on. So i went and took it apart piece by piece to see what was the problem. When i took off the RAM, the pc turned on and stayed on. When i put the RAM back, it would turn off after 3 sec. I tried this multiple times to see if it was actually the problem, and it was.
So what should i do, please help.
Does the mobo not support that type of ram or is it something else.

The motherboard is a Asus B85M-G
and the Ram is
G.Skill Sniper 8gb
Please help.
8 answers Last reply Best Answer
More about wrong ram
  1. ram frequency?
  2. link ram.

    and do you have 2 sticks or 1. and did you try 1 stick in different slots? and then take a different stick and try that in different slots?
  3. plaintuts said:
    ram frequency?


    1600
  4. swifty_morgan said:
    link ram.

    and do you have 2 sticks or 1. and did you try 1 stick in different slots? and then take a different stick and try that in different slots?


    I only have 1 stick its 8gb and 1600
    i tried it in all 4 slots and still nothing.
    Should i get a different ram or is it something else
  5. Best answer
    your ram stcik could be doa try to borrow one from a friend i would suggest if you could to get 2 x 4 gig ram module .
  6. scout_03 said:
    your ram stcik could be doa try to borrow one from a friend i would suggest if you could to get 2 x 4 gig ram module .


    Thanks, i checked the QVL, and the ram i bought wasnt there.
    So that list helped a lot for this problem and for future problems.
    Thanks a lot, keep in mind that this is my first build making me a dam noob haha.
  7. your welcome we always have something to learn .
Ask a new question

Read More

RAM Motherboards Memory