Solved

Windows 7 suddenly taking a long time to boot w/ SSD?

Hello everyone,

A few months ago my computer started taking about 3 minutes to boot with my SSD, which was up from about 15 seconds. This happened out of no where. I just now decided to try and fix the problem, and haven't had any luck. I have a plextor 128gb M5Pro SSD, with a 1TB WD Blue secondary drive. I have tried just booting up with the SSD (unplugging the WD Blue), installing new AHCI drivers, using different SATA ports, starting the computer with no usb devices plugged in, and reformatting my computer, all to no avail. I can't seem to find what the problem is. I have a Sabertooth 990FX R2.0 motherboard, with an AMD FX-8350 processor. Before the reformat, the computer would hang up before the windows splash logo. However, after the reformat it hangs up on the splash logo.

Does anyone know how to fix this?

Thank you.
4 answers Last reply Best Answer
More about windows suddenly taking long time boot ssd
  1. More than likely something got installed that is taking time to initiate. Have you run a virus check lately? Be sure to update your virus signatures first. And then run a malware check with Malwarebytes: https://www.malwarebytes.org/

    Have you got a lot of stuff loading in the background when Win starts? Check your tray for any items you can disable one by one at startup to see if it speeds things up.

    Finally, run CCleaner to get rid of registry errors and resource wasting junk files and other crap that is hogging clock cycles.
    http://www.piriform.com/
  2. clutchc said:
    More than likely something got installed that is taking time to initiate. Have you run a virus check lately? Be sure to update your virus signatures first. And then run a malware check with Malwarebytes: https://www.malwarebytes.org/

    Have you got a lot of stuff loading in the background when Win starts? Check your tray for any items you can disable one by one at startup to see if it speeds things up.

    Finally, run CCleaner to get rid of registry errors and resource wasting junk files and other crap that is hogging clock cycles.
    http://www.piriform.com/


    Well, I just reinstalled windows and formatted my hard drives yesterday. Even before installing any programs the problem still persisted. It seems like it's taking even longer to start now than it was before (About 5 minutes)
  3. Hmmm...

    I just installed Windows 7 SP1 and installed a few Windows Updates, and it looks like the problem is gone.

    Weird, I had SP1 on my previous install. Not sure how that would fix it, but for now it looks like the problem is solved.
  4. Best answer
    When you installed Win7 on your SSD, did you make any modifications to allow it to perform better? You need to do a few tweaks to the Win7 installation an a SSD that you do not need to do when installing to a HDD. These tweaks will help with performance and will keep it from writing itself to an early death.
    http://www.computing.net/howtos/show/solid-state-drive-ssd-tweaks-for-windows-7/552.html

    If you do another clean install of Win7 to the SSD, you find this interesting too:
    http://www.overclock.net/t/1156654/seans-windows-7-install-optimization-guide-for-ssds-hdds
Ask a new question

Read More

Boot Computers Storage Windows 7 SSD Western Digital