Sign in with
Sign up | Sign in
Your question

Please help I'm desperate.

Last response: in Systems
Share
May 17, 2014 3:04:46 PM

I am building a current gaming desktop. But there is problems... When i start the thing up nothing happens. The fans turn on but nothing comes up on the screen. No bios nothing, The computer makes no noise. It's not the screen because i'm using right now :/  I need to figure out whats wrong with it please!

AMD a6 5400k
Sapphire R9 270x toxic
Gigabyte GA-F2A88X-D3H
Cooler Master EXTREME 2 725watts
Two case fans
1TB HDD
DVD Drive
TP-Link 300Mbps PCI Express
Case: NZXT Source 210 Elite (White) ATX Mid Tower Case




More about : desperate

a b V Motherboard
May 17, 2014 3:08:03 PM

Since this is a new build and you don't know whats wrong you're going to have to breadbox it and basically build it outside the case and add one component at a time. starting off with just the CPU and MOBO to see if it will POST. If it does then you start adding one component at a time until you can reproduce the problem. Look up breadboxing a PC so you can follow the instructions.
m
0
l
a b à CPUs
a b V Motherboard
a b U Graphics card
May 17, 2014 3:11:47 PM

Check that your display is plugged into the motherboard, not the graphics card for first installation.
m
0
l
Related resources
May 18, 2014 8:47:37 PM

Thank you i figured out that the pins are bent :/  So yay... Gotta buy a new proccessor
m
0
l
a b À AMD
a b à CPUs
a b V Motherboard
a c 224 4 Gaming
a b U Graphics card
May 19, 2014 6:13:18 AM

Get a Athlon 750k. The A6 is a really weak processor and it would terribly bottleneck your 270x.
m
0
l
a b À AMD
a b à CPUs
a b V Motherboard
a b 4 Gaming
a b U Graphics card
May 19, 2014 6:37:30 AM

get the 750K or 760K

see if you can return the bad CPU
m
0
l
!