Sign in with
Sign up | Sign in
Your question
Solved

Ati Display Drivers won't install

Last response: in Graphics & Displays
Share
May 25, 2014 1:11:20 AM

just noticed a few days ago that my Display options are gone with ati/amd Catalyst Control Center ,
I downloaded the latest the 14-4-win7-win8-win8.1-64-dd-ccc-whql

and i do have Win7 Ultimate x64, its right, its proper, its legal even,
yet it always errors and says notes, Wrong Windows Version How??

don't know why when i first set this system up year or so ago it worked just fine,
suddenly i'm eh, Video card is a Radeon HD 5770. even tried to reinstall the original Disc
that came with the card and its messing up so unknown why

Best solution

May 25, 2014 1:16:31 AM

hahaha it's not the first time i've heard this one but i'll try my best to help xD. Right click the installer and run it as the administrator. Also if you've done a recover, repair, clone or you've broken your os before you need to reactivate it :) 
Share
May 25, 2014 1:16:54 AM

Ati has serious issues, I upgraded from a 5850 to a R9 270X and never could get it to instrall correctly, ended up having to reinstall win 7 64bit to get it working...
m
1
l
Related resources
May 25, 2014 1:18:18 AM

Ki11ian said:
Ati has serious issues.


Yup, the card are good but the only good software they have is mantle, the rest is really annoying and buggy
m
0
l
May 25, 2014 11:55:49 AM

lukelaw said:
hahaha it's not the first time i've heard this one but i'll try my best to help xD. Right click the installer and run it as the administrator. Also if you've done a recover, repair, clone or you've broken your os before you need to reactivate it :) 


>.<.. Figured as much, knew it had to be something. specially since i now have that Over Scan black bars going around my screen again
m
0
l
May 25, 2014 12:40:25 PM

If you have you product key just reenter it :) 
m
0
l
May 29, 2014 1:46:56 AM

lukelaw said:
If you have you product key just reenter it :) 


hate to say it i found my key <3 and it said it reactivated fine, but driver still wont Work

okay i take that Back i have my control center back i have the Over Scan back on no more Black border around my screen ,,, But ....


now my Hdmi screen is Black n White... >.< all i goto My Digital Flat Panels Display Color select the Acer s231hl and no color options whatsoever >.<

Okay Change that Unpluged the hdmi cable and switched to a Dvi cable and color came back so Either Hdmi is going nuts or it drivers didn't install correctly or the cable is going bad.


well its probably not the display adapter seeing how i just used my displayport and its adapter to get color back in my monitor.. Fudge
m
0
l
!