Sign in with
Sign up | Sign in
Your question

Windows CANNOT detect my phone after using DVD ROM

Last response: in Windows 7
Share
May 25, 2014 7:00:54 AM

Hi guys, im using Sony Xperia M
Today i used my DVD ROM for the first time this year and after that my PC cant detect my Sony Xperia M
It shows the device like this


I uninstalled it, and plugged it in, same problem
I updated the drivers, and it shows it as a MTP USB Device and says my drivers are up to date..but the yellow exclamation mark still exists
The phone supplied a PC Companion suite which cant detect my phone anymore
I went to Sony website to get drivers for this phone but they only offer PC Companion suite as a means to install its USB drivers and stuffs
My phone gets detected in any other PC and laptops. only in my laptop is it detecting like this

BTW what are those 2 "bluetooth pheripherals" with yellow exclamation marks?
May 25, 2014 7:14:56 AM

Try to restart your pc. If still the problem exists, then right click the device in device manager and click Uninstall. In the pop-up window, click Ok and also select 'delete driver software for this device' if such an option is found. Then restart your PC. Check your device manager and report it to me. (No PMs)
m
0
l
May 25, 2014 7:18:11 AM

I uninstalled it. The yellow exclamation mark disapears.
device status says "No drivers are installed for this device. "

I unplug, and plug, the same thing comes back with exclamation mark.
Restarted my laptop a lot of times
m
0
l
Related resources
May 25, 2014 7:24:14 AM

mikael_schiffer said:
I uninstalled it. The yellow exclamation mark disapears.
device status says "No drivers are installed for this device. "

I unplug, and plug, the same thing comes back with exclamation mark.
Restarted my laptop a lot of times


Right click the device and select Update driver software, and click search automatically for updated driver software. If it does not work, try to install the drivers which you have downloaded from the Sony website and restart the pc. and check whether there are 2 Bluetooth peripheral Devices with yellow exclamation marks and the main device too i.e Sony Experia M. I cant understand why usage of dvd drive would stop functioning of Experia M. anyway, why did you use dvd drive?
m
0
l
May 25, 2014 8:00:56 AM

i used the CD drive to install Alan Wake game
Sony website doesnt give any drivers, only SOny COmpanion Suite..which i installed and its not working. I acnt even uninstall it now, it gives an error code like this-
Error Code: -5005 : 0x80070002
Error Information:
>Kernel\KernelMedia.cpp (95)
>SetupNew\setup.cpp (817)
PAPP:Sony PC Companion
PVENDOR:Sony (http://www.sonymobile.com)
PGUID:F09EF8F2-0976-42C1-8D9D-8DF78337C6E3


I did system restore but still problem exists..
m
0
l
May 25, 2014 8:06:47 AM

mikael_schiffer said:
i used the CD drive to install Alan Wake game
Sony website doesnt give any drivers, only SOny COmpanion Suite..which i installed and its not working. I acnt even uninstall it now, it gives an error code like this-
Error Code: -5005 : 0x80070002
Error Information:
>Kernel\KernelMedia.cpp (95)
>SetupNew\setup.cpp (817)
PAPP:Sony PC Companion
PVENDOR:Sony (http://www.sonymobile.com)
PGUID:F09EF8F2-0976-42C1-8D9D-8DF78337C6E3


I did system restore but still problem exists..


I think your Xperia drivers are corrupted..... Did you do as i saind in the 1st line of my answer? (right click......)

m
0
l
May 25, 2014 8:21:44 AM

yes sir.
Ill do it all over again step by step
Right now it shows as MTP USB Device (not Xperia M anymore since i uninstalled it from Safe Mode)
Now i click update
It says" Windows has determined the device driver is up to date" and shows a MTP USB Device with small icon of a portable video player


Now uninstall method
I right clicked and uninstalled it, the yellow exclamation mark is gone. However when i double click it, its device status says "No drivers are installed for this device". If i make it autodetect driver it comes back to MTP USB Device again

If i unplug my phone and plug in, the yellow exclamation mark come back, back to square one..
m
0
l
May 25, 2014 8:30:24 AM

mikael_schiffer said:
yes sir.
Ill do it all over again step by step
Right now it shows as MTP USB Device (not Xperia M anymore since i uninstalled it from Safe Mode)
Now i click update
It says" Windows has determined the device driver is up to date" and shows a MTP USB Device with small icon of a portable video player


Now uninstall method
I right clicked and uninstalled it, the yellow exclamation mark is gone. However when i double click it, its device status says "No drivers are installed for this device". If i make it autodetect driver it comes back to MTP USB Device again

If i unplug my phone and plug in, the yellow exclamation mark come back, back to square one..


After some searching I have found driver: http://phonelane.com/downloads/sony-xperia-m-pc-compani... . Download the USB driver from this website and try to install.:

Step 1-Extract all the files in the zip files to an empty folder
Step-2-Select both the .inf files and right click and click install.
m
0
l
May 25, 2014 8:43:02 AM

i downloaded the new drivers, tried to UPDATE DRIVER, pointing the file location at the newly downloaded driver's folder...no use..keeps choosing MTP USB Device.
Is there something to do with Error Code 31?
m
0
l
May 25, 2014 8:43:10 AM

shall i try in safe mode?
m
0
l
May 25, 2014 8:46:16 AM

i think i cannot do anything now. sorry.
m
0
l
!