USB 3.0 devices not working in USB3 port, only recognizes USB2

Hi there and thanks for taking the time reading this.

I have an issue with the motherboard on the system i finished building recently. The problem that I'm having is that the USB3 ports are only working as USB2, and not USB3. Meaning, they do no recognize any USB3 devices but they recognize any USB2 device without problems.

I've never overclocked my system, I have installed all the drivers (USB3 included) that came with my motherboard and the USB3 cable from the 2 front ports is well seated in the USB3 header of the motherboard (not sure if this is relevant as the rear USB3 ports have the same issue).

Asus Crosshair V Formula-Z motherboard
AMD FX-8350 processor
Crucial Balistix Sport 1600MHz low profile RAM
CM Storm Trooper chassis
6 answers Last reply
More about usb devices working usb3 port recognizes usb2
  1. HAve you installed the Asmedia USB3.0 Controller Driver ?
  2. Hey and thanks for answering.

    Yes I have, I even re-installed it just to make sure it's there. I also flashed my BIOS, still not working. I'm totally at a loss here
    I'm using a 64 bitWindows 7 Ultimate btw, forgot to mention that.
  3. Look at the Device Manager --> USB Host Controller
    If you can see the Asmedia driver there, then go a buy a new USB3.0 device...
    You may have a crappy USB3.0 device
  4. I have tried the USB3 ports with more than 1 device - used a 16GB USB3 Kingston memory stick, also tried it with my Toshiba USB3 external hard drive. None work (but they work fine in the USB2 ports). And USB2 devices work fine in both USB3 and USB2 ports.

    Picture of my device manager:
    http://i.imgur.com/0VDXZXt.png
  5. Daft question, USB3 is enabled within the BIOS ?
  6. Yep, I think I've checked that one several times (before and after I flashed the BIOS) and it's all enabled.
Ask a new question

Read More

Storage Devices USB3 Motherboards Port