Solved

Corsair H80i. CPU fan error with Red Light on pump. help me please.

When i turn on my pc it boots into bios and shows cpu fan error. The pump is glowing red(not blinking).when i enter the bios by pressing f1. The rpm of cpu fan is N/A. The cpu temp rises and automatically shuts down.. I have looked the connections of h80i. All connections are good. Please help me to solve this one
13 answers Last reply Best Answer
More about corsair h80i cpu fan error red light pump
  1. Go through the h80i manual and double check that everything is plugged in right. http://www.youtube.com/watch?v=vz8NxKsjxKc

    If so, then it's probably a Corsair Link problem.

    Try the fans in a case fan header.
  2. The fans are spinning correctly.. But the pump turns red and shuts down pc.. Is it a pump failure
  3. OK - check with Corsair. The if need be, rma it.
  4. 1) The fan error would exist likely if using the Corsair setup and NOT connecting to the motherboard. In the BIOS the motherboard sees no CPU fan. So NOT an issue.

    2) PUMP color can be changed I believe so not necessarily a problem.

    3) SHUTDOWN and Overheating is obviously a problem so it sounds like a defective pump.

    4) So, contact Corsair to RMA.

    5) Another option is to RMA it, buy an AIR COOLER instead, then sell the returned cooler.

    *The Noctua NH-U12S is a really great cooler. With a good air cooler you can also run the computer even if the fan fails depending on the software running.
  5. I cutted the three pin molex cpu fan connector and replaced it with other three molex pin (it was loose.. shaking it made the pc to boot. So i thought it was the problem). Will they RMA the piece.. Im in india (rma is available here or not) .. Im in a pathetic situation please help me!!!
  6. Check with Corsair.
  7. Anyone.. Reply please..
    I cutted the three pin molex cpu fan connector and replaced it with other three molex pin (it was loose.. shaking it made the pc to boot. So i thought it was the problem). Will they RMA the piece.
  8. Best answer
    Check with Corsair. Good luck!
  9. praveen1996 said:
    Anyone.. Reply please..
    I cutted the three pin molex cpu fan connector and replaced it with other three molex pin (it was loose.. shaking it made the pc to boot. So i thought it was the problem). Will they RMA the piece.


    Not likely now that you did that.
  10. I also have the same problem, when I install my h80i not pass bios logo and Corsair flashes red, my motherboard is an Asus Rampage IV Gene, I could never fix and I had to buy another cooler.
  11. Try starting a thread
  12. corsair replied it as defective pump. so i rma'ed the peice and got a new one..5 months ago..sorry for late reply
  13. praveen1996 said:
    corsair replied it as defective pump. so i rma'ed the peice and got a new one..5 months ago..sorry for late reply


    Glad it's finally working.

    That's personally why I use a good air cooler as it functions even if the fan fails.
Ask a new question

Read More

BIOS CPUs Corsair