Solved

New PC Build. Z87-pro. Win7 Error: No device drivers were found.

Hello, I just built a new PC and i'm getting the following error when trying to install windows 7 from a USB: No device drivers were found. Make sure that the installation media contains the correct drivers.

My booting sequence is: USB -> Crucial SSD -> Hard Drive
I don't have DVD/CD-Rom Drive.

My Sata mode selection by default is: AHCI.
I tried copying the dvd drivers to another usb but the same error appears when i select it.

What i'm doing wrong? :/
5 answers Last reply Best Answer
More about build z87 pro win7 error device drivers found
  1. Best answer
    It sounds like your USB key image is improperly made. Try following this guide:

    http://www.techrepublic.com/blog/windows-and-office/configure-a-usb-flash-drive-to-be-a-windows-7-installation-platform/

    I format the USB key to NTFS but you can format it to FAT32 and everything will work fine.
  2. Check if you can read the usb stick in another pc.
  3. I'm using Windows USB/dvd download tool. Let me try your link.
  4. Eureka! That was it. It's installing now. Thanks
  5. Nothing works...
Ask a new question

Read More

win 7 SSD No device z87Pro Windows 7