Sign in with
Sign up | Sign in
Your question
Solved

FPS in game drop suddenly

Last response: in Graphics & Displays
Share
May 30, 2014 8:10:00 AM

I am trying to play Archeage alpha but the game stutters and stalls every few seconds and the FPS suddenly drops from around 47 to less than 5 and then back up again. What could be causing this? My specs are
Athlon X4 750K Trinity 3.4ghz
Radeon HD 7950 3GB
8GB RAM 1600

More about : fps game drop suddenly

May 30, 2014 8:11:56 AM

Well if ArchAge alpha is your only issue, you are best off to take it to the forums there. (I am assuming they have one)
m
0
l
May 30, 2014 8:15:33 AM

Nordein said:
Well if ArchAge alpha is your only issue, you are best off to take it to the forums there. (I am assuming they have one)


Honestly, I haven't tried to play any other games as this is the only one I have installed right now. I have the latest driver and have made sure nothing is running in the background. Im assuming its a problem with the system and not the game.
m
0
l
Related resources
May 30, 2014 8:17:20 AM

deadtom said:
Nordein said:
Well if ArchAge alpha is your only issue, you are best off to take it to the forums there. (I am assuming they have one)


Honestly, I haven't tried to play any other games as this is the only one I have installed right now. I have the latest driver and have made sure nothing is running in the background. Im assuming its a problem with the system and not the game.


Test out some other games that will stress your rig to help pinpoint if it is a optimization issue with ArchAge or your hardware.
m
0
l
May 30, 2014 8:21:32 AM

Nordein said:
deadtom said:
Nordein said:
Well if ArchAge alpha is your only issue, you are best off to take it to the forums there. (I am assuming they have one)


Honestly, I haven't tried to play any other games as this is the only one I have installed right now. I have the latest driver and have made sure nothing is running in the background. Im assuming its a problem with the system and not the game.


Test out some other games that will stress your rig to help pinpoint if it is a optimization issue with ArchAge or your hardware.


Ok. I ran Heaven benchmark and it had no issues like i'm getting in the game and got a score of 1350 or something. Should I run another game anyway?
m
0
l

Best solution

May 30, 2014 8:23:51 AM

deadtom said:
Nordein said:
deadtom said:
Nordein said:
Well if ArchAge alpha is your only issue, you are best off to take it to the forums there. (I am assuming they have one)


Honestly, I haven't tried to play any other games as this is the only one I have installed right now. I have the latest driver and have made sure nothing is running in the background. Im assuming its a problem with the system and not the game.


Test out some other games that will stress your rig to help pinpoint if it is a optimization issue with ArchAge or your hardware.


Ok. I ran Heaven benchmark and it had no issues like i'm getting in the game and got a score of 1350 or something. Should I run another game anyway?


Just to be safe I would stress test a few other games.
Share
May 30, 2014 8:24:58 AM

Ok, thanks
m
0
l
May 30, 2014 8:31:17 AM

No problem dude. Come back with your results and we can discuss if there is any issue. :)  Thanks for choosing me as the answer. (despite me being the only one) :p 
m
0
l
!