Cannot change network adapter settings!

Hi.
I have issues with my Internet connections and called my ISP for the issue,where they suggested me to use a spesific DNS number they told.However, when I try to open the "Change Adapter Settings" tab on Network and Sharing Center,all I get is a blank page with no connections listed.
My internet works,but I cannot access the window where I can manage protocols to change my DNS.
How can I fix this,or is there some other way I can edit the DNS?

Thanks.
15 answers Last reply
More about change network adapter settings
  1. If It was working before you could try either:
    Rolling back your drivers.
    You can do this in the settings via the network adapter settings panel
    Or you can roll your computer back to a previous point in time using start up repair (That's if it was working before)
    Hope this helps!
  2. Well,it's been a real long while since I last tried changing DNS settings.
    So yeah,it was working at one point,but I'm talking about months,if not years here.So I really have no idea when it stopped working.But seems like long before I noticed,because rollbacks didn't help unfortunately.
  3. What kind of network adapter is it?
    Internal or external like a USB adapter or a Wifi card
  4. I'm not sure to be honest.It's not external for sure.The machine I'm using is a laptop,so it has Wi-Fi.But it also has a socket for cable connection.When I chack the devices in Device Manager,I see 3,called:

    -Atheros PCI-E Fast Ethernet Controller
    -Broadcom Network Adapter
    -Microsoft Virtual Wi-Fi Miniport Adapter.
  5. Well the virtual Wi-Fi miniport is used for broadcasting a wireless signal so to me it looks like a wifi card.
    They can be disconnected.
    Is it giving any more details on the Broadcom adapter? like a model?
    As we need to manually update your drivers
  6. It says Broadcom 802.11n Network Adapter.
  7. What's your laptops make/model?
  8. It's Toshiba but I have no clue what's its further model name is.
  9. I've had a look around and I cant seem to find your drivers from any "Safe" website as most of them are viruses.
    You could try a utility to change your DNS like http://download.cnet.com/DNS-Changer/3000-2094_4-75322300.html
    Hope this helps!
  10. Thanks for your help and effort.

    I tried the program above,which led to a very interesting prompt:
    When I launch the program,it says "Changing DNS servers is not supported in your current configuration!"

    I really wonder what I've done now...
  11. Are you still getting internet?
    I wonder if there is something wrong with the card itself...
  12. Yes,I can connect to websites and work programs such as Skype and Steam.
  13. Ummm... im not sure if this is going to work as you may not be able to access the panel.
    but try doing this:
    Go into "Control panel"
    then click "Network and internet"
    Then click "Network and Sharing center"
    Then on the left panel click "Change adapter settings"
    Select your device and then right click on it and select "Propeties"
    Then click "Configure"
    Then select the "Driver tab"
    Then try "Update driver..." first and then "Roll back driver" if the first one doesn't work.
    Hope this helps!
  14. Yeah,the problem is that there are no devices displayed when I click "Change Adapter Settings"...Just a blank page.
  15. Lets try resetting your control panel.
    Please note you are going to need to go into the "Registry editor", if done wrong this can seriously mess up you machine.
    Ill make a list of instructions that's as detailed as possible.
    1. First hold down the "Windows icon" and "R" at the same time until a windows appears at the bottom right of your screen.
    2. This windows should be called "Run", type in the box "Regedit" and then click "Ok" it may ask for your permission.
    3. On the left panel double click on "HKEY_LOCAL_MACHINE", then "SOFTWARE", then "Microsoft", then "Windows", then "CurrentVersion", then "Control panel", then finally double click "Don't load.
    Insure that you have got to the correct screen: http://cdn.howtogeek.com/wp-content/uploads/2007/08/image1.png
    (Please note your may have a few more or a few less items on the right panel)
    4. then look for "ncpa.cpl" (This is the network connections folder), select the folder once then right click on it and then select "Delete"

    Now see if that has restored the settings correctly
    Hope this helps!
Ask a new question

Read More

Internet Service Providers Windows 7 DNS Internet