Sign in with
Sign up | Sign in
Your question
Solved

R9 270X Major Out Of the Box Driver Issue ! Need help !

Last response: in Graphics & Displays
Share
May 31, 2014 9:51:43 PM

Hello , Im quite new to forum posting but seeing as this problem has gone beyond my expectation I thought I'd ask for help from more knowledgeable folks.

So heres the problem , I got my R9270X Vapor a week ago . I installed everything as usual (fitting the card , driver installation) but after rebooting my pc , I get a blank screen. It did however pass the windows startup logo. So seeing as the provided driver in the CD was pretty much half-assing its purpose , I scoured the AMD download page for a different version. As you would assume I tried the latest driver which was the 14.4 driver and even the 14.6 beta driver but again with the half-assing , blank screen.

So again I scale down from release to release and finally found that version 13.6 works , but now suddenly the major issue is the driver has finally crapped out and I cant even run games anymore without it freezing my PC.
I also noticed that a lot of people are having this blank screen issue from updating drivers . But this is really frustrating because out of the box this happens.

So, I was hoping that you guys might have any opinions or thoughts on how I can at least get it to run games again or update the drivers.

Here some useful specs:

GPU: Sapphire R9270X Vapor X
MOBO: Gigabyte H81M-S2PV
PSU: Thermaltake LitePower 600W
OS: Windows 7 Home Premium 64-bit
CPU: Intel Core i5 4440 Haswell with integrated graphics (disabled)


Thanks in advance for your support !

May 31, 2014 10:11:10 PM

It could be a defective card. What temperature is the card running at? What do you mean when you say "blank screen"? Is the computer responsive when the screen is blank (for example, does the caps lock work)?
m
0
l
May 31, 2014 10:32:21 PM

LimitedWard said:
It could be a defective card. What temperature is the card running at? What do you mean when you say "blank screen"? Is the computer responsive when the screen is blank (for example, does the caps lock work)?


The card runs really cool (average 55C - 63C) since Im running fan direct into the computer . And no the computer is completely unresponsive when I get the blank screen .
m
0
l
Related resources

Best solution

May 31, 2014 10:43:45 PM

Aiman Zamir said:
LimitedWard said:
It could be a defective card. What temperature is the card running at? What do you mean when you say "blank screen"? Is the computer responsive when the screen is blank (for example, does the caps lock work)?


The card runs really cool (average 55C - 63C) since Im running fan direct into the computer . And no the computer is completely unresponsive when I get the blank screen .


And this happens every time you boot? Is this an entirely new computer, or did you simply upgrade the card? Perhaps swap back to the old card (if you have one) to see if it's actually a problem with the 270x, and not with any other components. What PSU do you have?

I know I was having some trouble with my computer when I first got it (it has a 270x as well). I found that every once in a while it would freeze for no apparent reason, and sometimes it would cause a blank screen. It has never happened to me on bootup, though.
Share
May 31, 2014 11:05:28 PM

The computer is pretty much new , built it last year . Used the integrated graphics until I got the R9 . I'm using a Thermaltake Litepower 600W which is guess is enough headroom ? But if this problem still persists I think I'll just take it back , like you said it could be the card itself which at this point makes the most sense .
m
0
l
!