New Computer Built - Display Randomly Turns Off [No Signal]

Hi! It's been 3 days since I have completed building my computer. However, just an hour ago, something strange happened. While watching a YouTube video, the screen suddenly went black and the [No Signal] display was shown. Nothing was showing. The audio sounded "stuck" as if the last sound was stayed on. The computer was indeed running, so I doubt it was the PSU. Then the computer rebooted itself. As soon as I opened Google Chrome, the display disconnected again. This would happen a few times, whether or not a program was open. An hour has passed and everything seems sound now, but I was wondering what could have cause that and if there was really a problem with my PC. I ran Prime95 and a CPU temperature of 72C seems fine.

Update: Just an update. While running 3Dmark demo with the Starcraft spoof thing. The HDMI signal was lost. Sound continued until the end. From there I had the reboot the pc

Reading the logs, the things the seemed weird were
Display driver nvlddmkm stopped responding and has successfully recovered.
The following boot-start or system-start driver(s) did not load:
dam
4 answers Last reply
More about computer built display randomly turns signal
  1. Have you tried checking your memory and seeing if the PSU cables were all plugged in correctly?
  2. Probably a motherboard or psu problem. The psu could be randomly having wattage fluctuations. You could replace the psu or plugging the psu directly into a wall socket.
  3. Zokuta said:
    Have you tried checking your memory and seeing if the PSU cables were all plugged in correctly?

    yep its all fine
  4. dorky1 said:
    Probably a motherboard or psu problem. The psu could be randomly having wattage fluctuations. You could replace the psu or plugging the psu directly into a wall socket.


    ill plug it in the wall socket and see if there is a difference
Ask a new question

Read More

Computers Systems Displays