Sign in with
Sign up | Sign in
Your question

Cannot connect to unsecure wifi anymore.

Last response: in Wireless Networking
Share
June 3, 2014 8:03:10 AM

Please help, I'm at a loss!! I have a dell vostro using windows 7 that will only connect to secure wifi. This started about 6 weeks ago. Have had it for a few years and always connected to public unsecure networks. I've tried every fix that I could find online over the last 6 weeks. Drivers are up to date. Network card is showing all the unsecured but says windows was unable to connect to network when I try to connect. I've tried turning off firewall both in windows and mcafee. I've tried restoring the computer to a date that I know it connected previously, I've tried restoring to default settings. It connects just fine if I'm on a secure wifi network or cable. If I'm trying to connect to unsecure wifi Ipconfig just shows media disconnected on all fronts. It's a dell wireless 1702 802.11b/g/n adapter. I've also been able to connect to phone hotspot which says its public but needs a code to connect so I'm assuming the difference there is it's secure. Seems that it's specifically unsecure open wifi networks that are the problem (work, Starbucks, etc) Also, I know that these unsecure networks are accessible because I am able to connect with both iPad and iPhone. Any help would be greatly appreciated. Unfortunately I cannot include ipconfig snapshot because I'm at work and only have internet access on my iPad.
a c 323 $ Windows 7
June 4, 2014 8:39:32 AM

Did you by any chance update the wireless driver on your Vostro just before you first noticed that connection problem?
If yes, roll back the driver in Device Manager > [Name of Wireless Device] > Driver (tab).

If you didn't update the driver, try the opposite by updating it from Dell's website.
Go here and enter the Dell Service Tag (sticker underneath):
http://www.dell.com/support/my-support/uk/en/ukbsdt1/Pr...

If it's not a UK model, click "United Kingdom" at top-left of page for a drop-down country menu.
m
0
l
June 5, 2014 12:37:39 PM

Thanks Phillip. I did not update driver before having the problem but have since brought the laptop home where I can connect and updated the driver.
m
0
l
Related resources
June 23, 2014 9:23:50 PM

I just posted the exact same issue. Have you tried:
- reset netsh
- reset winsock
- turn off all 3 windows firewalls? (Domain, public, private)
- safe mode networking
- "clean boot"
- reset TSP/IP
- completely removed anti-virus
- turn off netsh firewall

m
0
l
June 24, 2014 6:54:34 AM

Foxdie50 said:
I just posted the exact same issue. Have you tried:

- reset netsh ----- Yes
- reset winsock ----- Yes
- turn off all 3 windows firewalls? (Domain, public, private) ----- it says my firewall is controlled by McAfee so I turned it off through there. I cannot find any way to turn it off through windows.
- safe mode networking ----- I am not that techie and do not know what this is.
- "clean boot" ------ Again, do not know what this is.
- reset TSP/IP ----- Tried to but it won't reset.
- completely removed anti-virus ---- No, but I disabled it.
- turn off netsh firewall ----- Do not know how.



m
0
l
June 25, 2014 8:41:59 AM

Turn off all firewalls:
Start > control panel > system security > windows firewall > advanced settings > windows firewall properties > (cycle through domain, private, and public tabs, turn each OFF.

Safemode W/ networking:
Start > run > msconfig > general tab "normal boot" > boot tab "safe boot (select "Network" bubble) > apply > restart
The point is to test if something is blocking your connection that's software related

"Clean boot"
Msconfig > general tab > "selective startup > "load system services" selected & "load startup items" DESELECTED > services tab > "hide all Microsoft services > disable all > apply > restart
Similar to Safemode. W/networking but this removes all programs that may initially impacting the WLAN

Reset TCP/IP:
Start > CMD > netsh int ip reset resettcpip.txt > restart

Netsh firewall:
Run > CMD > netsh > firewall > show mode (it will say online) > offline > show mode (it will say offline) > bye > quit
This is just another way of ensuring any firewall is not still active.
m
0
l
June 25, 2014 9:40:46 AM

Foxdie50, thanks for taking the time to try to help. I followed every step and unfortunately still not able to connect. It's driving me crazy. I purchased a USB network adapter that should be delivered today so I'm hoping maybe that will do it. I have no idea what could be the problem.
m
0
l
June 25, 2014 12:09:27 PM

Interesting. See, I'm troubleshooting the exact same issue, all I can so is have you try the things I've tried. I have a Killer Wireless N-1103 WNIC. I had just found out I can connect to one particular wifi network at the library and it's unsecured. Strange. So now my WNIC will connect to some and not others. You mentioned home, work, Starbucks, etc. just curious, what IS the ect? Because you just might be able to connect to a nonsecure but have been unsuccessful thus far. Also, I plugged in a USB Wifi dongle and now I can connect too. Very strange indeed.
- ok so maybe go out and try to connect to open wifi networks you have yet to try.
m
0
l
June 25, 2014 12:43:52 PM

I was able to connect to home wifi and also by teathering my husband's phone. I am in the city so there are many public buildings that have public wifi that I was not able to connect to. I work in a building with public wifi that I've always been able to connect until about two months ago. I've also gone to Starbucks and was not able to connect. The good news is that my usb wireless dongle finally arrived and now I can connect using that. I have no idea. Maybe the network adapter was just on the way out or something. Very strange. I'm just happy it finally works. Thanks for trying to help. I hope you are able to figure out what's going on with yours.
m
0
l
June 25, 2014 12:47:18 PM

Ok so your wifi chip was also wonky. I have a completely different chip, same thing going on. I'm not sure if the two chips have some deep rooted setting I'm unfamiliar with but it is strange. Usually these things don't "start to go out" they just drop dead so that's unlikely. If I ever figure it out I'll repost here.
m
0
l
June 25, 2014 12:56:01 PM

Please do. Good luck.
m
0
l
!