Sign in with
Sign up | Sign in
Your question
Solved

GPU not powering up/ fans and leds on case work. please help

Last response: in Systems
Share
June 3, 2014 8:57:52 PM

Hi everyone i was recently cleaning dust from my pc and fans and after removing the GPU for a wipe down with a paper towel to remove dust i hooked it all back up when i was done and everything powers up except my video card the fan on the card wont even come on and the monitor is black can anyone please help me out i would be so grateful

specs:
motherboard: MSI FM2-A85XA-G65
cpu: AMD A10-6800K Richland 4.1GHz (stock cooler)
psu: Thermaltake 600w atx 12v
gpu: HIS H785F2G2M Radeon HD 7850 2GB 256-Bit GDDR5 PCI Express 3.0 x16
ram: 16gb pny

damric fixed it, just a problem of a tiny bit of cable management
a b U Graphics card
June 3, 2014 9:05:44 PM

Clumsy hands :D 

Go back in and make sure your power connectors are connected. Disconnect them and re-connect them.

Same with the Graphics Card. Take it out, and re-seat it.
m
0
l
June 3, 2014 9:08:52 PM

damric said:
Clumsy hands :D 

Go back in and make sure your power connectors are connected. Disconnect them and re-connect them.

Same with the Graphics Card. Take it out, and re-seat it.


I have the 6 pin PCI-E cable plugged in and nothing happened, I tried switching the card to the second slot and that didn't work either, I also tried using the second 6 pin connector for my psu and that had no effect
m
0
l
Related resources
a b U Graphics card
June 3, 2014 9:11:09 PM

Show me a picture of your rig with side panel off.
m
0
l
June 3, 2014 9:17:00 PM

damric said:
Show me a picture of your rig with side panel off.




I really need zip ties tomorrow
m
0
l

Best solution

a b U Graphics card
June 3, 2014 9:23:05 PM

Grecco1 said:
damric said:
Show me a picture of your rig with side panel off.




I really need zip ties tomorrow


lol I almost had a panic attack when I saw that. You can use bread ties or rubber bands if you have no zip ties. I suggest unplugging all of that mess and taking your time and make it all neat. I have a feeling that magically it will work when you do that :) 
Share
June 3, 2014 9:24:12 PM

damric said:
Grecco1 said:
damric said:
Show me a picture of your rig with side panel off.




I really need zip ties tomorrow


lol I almost had a panic attack when I saw that. You can use bread ties or rubber bands if you have no zip ties. I suggest unplugging all of that mess and taking your time and make it all neat. I have a feeling that magically it will work when you do that :) 


haha will do since it is late ill get on that first thing tomorrow and hope fully i wont be back thanks for your help :) 
m
0
l
June 3, 2014 9:25:51 PM

Re-seat it again, pull battery and jump/clear CMOS
m
0
l
!