Sign in with
Sign up | Sign in
Your question

Help! - Graphics settings won't stick in Nvidia Control Panel

Last response: in Graphics & Displays
Share
June 4, 2014 8:11:43 AM

For a while now, Nvidia control panel's been my go-to place for graphics tweeks after enabling things in NvidiaInspector, but it isn't working anymore. I hope you can help based on what I typed up below and this YouTube video to help you visualize things. Thanks in advance! :) 

Brief description of the problem
What happens in Nvidia Control Panel is that all settings revert to default after I make changes and press "apply." Specifically, the change I am talking about are in the "Manage 3D Settings" section of Nvidia Control Panel.

Making changes appears to behave the same as back when it was working, but it just doesn't stick. For instance, after clicking "apply," the computer will lag for a brief second while making the settings I specified, and like normal the updated settings will appear in bolded text to signify the change. When I switch to a different area in Nvidia Control Panel (e.g. "Configure Surround, PhysX") and then switch back to "Manage 3D Settings," however, all settings have reverted back to their unaltered state. The same thing happens if I close and reopen Nvidia Control Panel or restart the computer - wtf?!

What I've tried so far without success
I've uninstalled my drivers using Display Driver Uninstaller (formerly knows as Driver Sweeper) version 12.7.1. Here is the link I used to get it: http://www.guru3d.com/files_get/display_driver_uninstal...
I only used DDU without uninstalling drivers manually first, which may have something to do with it. I'll keep troubleshooting, but my attempts at this point will be a stab in the dark (thank goodness for Tom's!).

My current setup
I have a main GPU and a secondary one dedicated to PhysX, which has posed no problems until recently. My driver is up to date as of the time I wrote this (337.88). My full setup is in the signature.

If you need anything else to make a suggestion, just let me know, and I'll update this post accordingly.

Thanks!
June 5, 2014 6:24:20 AM

Install some older drivers (until a more latest driver is released) and see if the problem persists.
But first uninstall the current version with Driver Sweeper.
m
0
l
June 6, 2014 1:08:16 PM

Finally fixed it. For some reason DDU (aka Driver Sweeper) doesn't remove everything unless you manually uninstall everything related to Nvidia first. Doing that, however, removed everything successfully. Nvidia Control Panel works perfectly now! :D 
m
0
l
!