Sign-in / Sign-up
Your question
Solved

Can't change RAM speed on new Motherboard.

Tags:
  • RAM
  • Speed
  • Motherboards
  • Memory
Last response: in Memory
a b V Motherboard
June 5, 2014 4:35:01 PM

I recently acquired an Asrock Z97 extreme4 motherboard along with an i7 4770K cpu.

Everything seems to be running fine except that I cannot seem to change the clock speed. My ram is rated for 1600 and was clocked as such on my old board, but when I try to set the ram to 1600 with either the XMP profile or manually setting it to 1600, the system fails to initialize after exiting the bios and I have to reset my mobo settings.

I tried disabling the cpu overclock that I had set up, but no change in the results.

Can anyone help me?

More about : change ram speed motherboard

a c 436 V Motherboard
a b } Memory
June 5, 2014 4:46:32 PM

What is the memory kit model?
m
0
l
a b V Motherboard
June 5, 2014 4:54:34 PM

Mushkin Enhanced Radioactive 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model 997005

I have two sets for a total of 16GB RAM. In addition, I tried them again after in the motherboard I just upgraded from, and they still clock to 1600 without an issue on that board. There's a new BIOS update for my board. I wonder if that will improve ram stability, but it looks like it's just for the Devil's Canyon CPUS and the anniversary Pentiums.
m
0
l
Related resources

Best solution

a c 436 V Motherboard
a b } Memory
June 5, 2014 5:00:06 PM

Try all sticks one at a time in each slot. Maybe a bad slot?
Share
a b V Motherboard
a b } Memory
June 5, 2014 5:08:38 PM

Does that model appears in the mobo QVL list of compatibility?
m
0
l
a b V Motherboard
June 5, 2014 5:58:40 PM

I just tried each slot with each stick of memory, and it sets to 1600. So its unlikely that its a bad stick or memory slot. It seems that when I get to 4 sticks it just doesn't want to cooperate. I'm stumped.

6R1M01R3 said:
Does that model appears in the mobo QVL list of compatibility?


No idea. Its been years since I've taken those lists seriously and glanced them over.

Usually if memory isn't compatible, the system just won't boot at all. It my case here it boots just fine, I just can't seem to tweak my memory settings with 4 sticks of ram.
m
0
l
a b V Motherboard
June 5, 2014 6:27:48 PM

Anyways I've figured it out. It was something stupid. I had the timings set to the default auto, because the settings 9-9-9-24 were displaying properly in the BIOS and I didn't have to tweak them on my last board. Anyways I manually set the timings and my memory is now running at 1600.

Although it's awfully strange that it would work before with 3 sticks but not 4.

Oh well thanks for the help folks.
m
0
l
a c 436 V Motherboard
a b } Memory
June 5, 2014 6:36:17 PM

Glad you figured out the problem.
m
0
l