Solved

Trouble updating bios

Hello, first post here. Im having trouble updating my bios. I have an Asus p8z77-v lk and I've tried with a flash drive also with Ausu Suite II and am getting " The model of the bios image doesn't match the bios rom currently present". From version 1301 to 1402. I dont really need to update the bios but it says it improves memory capability so I figured why not. Any ideas why its saying this?
7 answers Last reply Best Answer
More about trouble updating bios
  1. Best answer
    What OS?
  2. Windows 8.1
  3. oops
  4. Do I use the bios renamer and a flash drive?
  5. Download the BIOS update and then unpack it. Copy the unpacked file to a USB drive with nothing else on the drive. Install the USB drive and boot into BIOS. There are step-by-step instructions in MB manual, section 3.10.2 for the rest of the steps.
  6. Awesome, now it worked. For some reason the bios wasnt reading it on the usb drive. Thanks spooky2th!
Ask a new question

Read More

Asus BIOS Flash Drive Motherboards