Solved

AMD CrossFire option not showing up in CCC

Hardware that seems relevant:

Things I have done to try and resolve this:


I feel like I've tried everything that I can think of and from what I can google, so now I'm here. :|
12 answers Last reply Best Answer
More about amd crossfire option showing ccc
  1. Have you got the xfire bridge on from card to card?

    Are both cards locked into their pcie slots?

    Are the power supply connectors on both cards?

    Do both cards show up in Device Manager? And working OK?

    Do you need to update CCC?
  2. Yes.

    Yes.

    Yes.

    Yes.

    No? I just stated that I tried both of the newest versions.
  3. Well something isn't working.

    Sure you've got it set up right in CCC?

    I'm not talking about drivers. I'm talking about CC being up to date.
  4. I downloaded CCC directly from the website. I clicked on Update at the bottom and it says everything is up to date.
  5. Hmmm OK. I'm running out of ideas.

    Does the card work in another pc?
    Does another card work in your pc?
  6. Both cards work fine when plugged in by themselves. Windows is picking up the other card and reads it in the Device manager but still no CrossFire option.
  7. A few things:

    Just to be sure, have both cards got the same amount of VRAM?

    Someone recently said that their bridge had to be slightly less than all of the way on to work properly, could try that

    It sounds to me like a faulty bridge cable (Failing my other 2 suggestions), so if you could find another one of those then try that (If anyone you know has bought an AMD card then they should have one)
  8. @i7Baby - The PSU is Coolmax CUL-750b and should be compatible.

    @CGurrell - They're the same exact cards. The bridge is brand new and I've tried the second, since I have two. I'll try the whole, "not on all the way" bit, but that sounds sketchy.
  9. Best answer
    Your psu should be per - http://www.tomshardware.com/answers/id-1804779/power-supply-unit-tier-list.html - preferably Tier One.

    Those specific models aren't in any Tier. By default they are in Tier Five - 'immediately replace'. At least think about it.

    And yeah - some bridges you do have to push hard to get them on properly.
  10. Cody Sommers said:
    Hardware that seems relevant:

    Things I have done to try and resolve this:


    I feel like I've tried everything that I can think of and from what I can google, so now I'm here. :|



    So I've got the same problem with my two 7970's. This is a very. Common problem since 14.4 release. To fix this completely erase all and drivers. Roll your drivers back to an older version. Say 13.12 or something. This will usually remedy the problem. Crossfire will now be available again. Now from here go to catalyst uninstall manager. Do a custom uninstall. Uninstall only the display driver. Leave everything else. Now install the latest GPU driver compatible with your gpu's. Make sure to do a custom install and Install the display driver only. You should now have crossfire option with the new driver you want to use.
  11. Knew it wasn't a hardware issue as I was running windows tech preview 64 bit and xp 64 bit dual boot. Crossfire works awesome on tech preview with omega drivers. Completely even GPU utilization with mantle. Now the newest driver for xp 64 bit is 14.4. No crossfire option. Rolled back to 13.12. Had crossfire option. From there I uninstalled the 13.12 display driver by itself. Rebooted. Then installed the 14.4 display driver. Worked for me. Your basically using an older CCC with the newer driver. Hybrid driver technology. What AMD should call it. Lol.
Ask a new question

Read More

Graphics Crossfire Option