Solved

Computer won't boot to OS after fresh install(specifically after gfx driver install)

Hey guys!
Basically my problem is as the title says, so I got a new HDD due to my old one dying on me. The OS install itself goes fine, but my problem is once I install my graphics driver, after the required RS of the system I'm presented with a lovely black screen after the windows logo. There was no problem with my gfx card prior to getting this new HDD.
(Machine specs:
CPU: AMD Phenom II x4 965BE
MOBO: ASRock Extreme3 970
GFX: Asus EAH 6870
HDD: Seagate 500GB HDD
PSU: Akasa VenomPower 750w
RAM: 8GB Cruical DDR3)

I'm not too sure what to do, as the mobo itself doesn't have onboard graphics so as it can't be a problem caused by the mobo gfx taking over after the first boot. And I don't think it's a problem with the gfx card due to the fact it's the only display unit on my machine and is working fine up to the time I install the driver. I've tried installing the driver from the asus site as well as a 3rd party site with the same results. Any help or suggestions would be greatly appreciated!
4 answers Last reply Best Answer
More about computer boot fresh install specifically gfx driver install
  1. Dod you install the motherboard chip set drivers
  2. @getochkn
    Yeah the seem to go through fine, its just once I put on the 6870 driver my problem seems to occur.
  3. Best answer
    try an older driver maybe. I had a brand new system, new gpu, 260x, and same prob, had to take it back and go nvidia. no way around it.

    some suggestions I got though was when installing the AMD drivers to NOT install the AMD ACHI driver. some say it worked for them, me, I shouldn't have to do that and said screw it and swapped video cards.
  4. @getochkn Cool I'll try that out once I'm home and let you know the outcome, thanks for all your help so far :)
Ask a new question

Read More

Computers Boot Hard Drives Graphics