Problems setting up Internet connection with Modem and wireless router

Have Comcast cable internet. Purchased a new Motorola Surfboard SB6141 modem, and have a wireless Belkin G router from 2010. Modem is receiving Internet connection fine, router seems to be as well, according to the lights on each device. Cannot get an Internet connection to save my life! Have connected with the ethernet cable and have tried setting up a wireless network but yielding no results. Is my router the problem? Any help in fairly plain English would be great as I've tried playing with several settings to no avail. I'm not extremely tech saavy, I apologize!
3 answers Last reply
More about problems setting internet connection modem wireless router
  1. Try rebooting the modem then reboot your router. I had the same problem when I first signed up with Comcast. It forced me to hook my laptop directly to the modem to register and get internet going. Then when I connected it to my router it did not want to work because it had already learned my MAC address from my laptop. I had to reboot everything and then wait about 2 minutes and then it stared working.
  2. I Have reset both about 3 times each.. nothing has helped. I even put the set up disc in that came with the Belkin G router to set up my Internet and then after that, set up my wireless but neither have worked.
  3. I am having similar problem with Comcast modem and Linksys EA2700 router. Hardwired internet works, can't connect to wireless. Call linksys and they want to charge $29.99 to reconnect me. I already tried to reset router 3+ times, renamed network and new password. I think I need to reset the IP address but I don't know how to do that.
Ask a new question

Read More

Wireless Router Routers Modem Wireless Network Internet Connection