Sign in with
Sign up | Sign in
Your question

Asus Maximus IV hero

Last response: in Motherboards
Share
June 12, 2014 6:47:41 PM

I m need to assembling pc parts plz help me with all connectors of board and case.. and what should I do after I first boot up my pc after I ahve completely assembled my system.
Specs are

I7 4770k
Asus maximus iv hero
16gb 8x2 corsair Vengeance 1866mhz
120gb kingston v300 ssd
4tb wd hdd
Thermaltake 730 smart psu
Thermaltake 3.0 water performer cpu liquid cooling

More about : asus maximus hero

a c 331 Ĉ ASUS
a c 1315 V Motherboard
June 12, 2014 6:54:01 PM

Thermaltake 730 smart psu < First thing , should be to replace a very poor supply
m
1
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
June 12, 2014 7:16:20 PM

Planning a GPU in the future? PSU will depend on that fact and what GPU you will need. Would also drop the CPU cooler a Hypre 212 EVO will cool better and runs half the price. Once all is together, first thing would be to load all the latest mobo drivers from the Asus website and while there check for the latest BIOS, then load Windows and get Windows all updated
m
0
l
Related resources
June 30, 2014 3:05:53 PM

Tradesman1 said:
Planning a GPU in the future? PSU will depend on that fact and what GPU you will need. Would also drop the CPU cooler a Hypre 212 EVO will cool better and runs half the price. Once all is together, first thing would be to load all the latest mobo drivers from the Asus website and while there check for the latest BIOS, then load Windows and get Windows all updated




m sorry for late reply
should i download all drivers ???
m sorry im not much in computers
but in asus websiteit shows 12 drivers for bios11 for sata and lots of others /??? can u help me here ???
can u suggest me which drivers should i download with my build dats all for now included in my build without GPU instead i will be using my old one geforce gt 630 2gb for awhile before buying new
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
June 30, 2014 4:20:02 PM

Should have said 'then load all the Windows updates' sorry, my bad!, was in a bit of a hurry (so Win, mobo drivers, then Win updates)........and on the Drivers, just download and load the latest version of each, generally when you get the mobo the drivers on the CD that came with it are already outdated.....
m
0
l
June 30, 2014 5:09:41 PM

I have just bought a software named as " uniblue powersuite 2014" it says it auto downloads all latest drivers.. so should I install win n den run this software to install all drivers and then win updates? ?
And about the Psu is it good enough with my build? And if I add a gtx 770 4gb will this psu will be running well ?
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
June 30, 2014 5:29:00 PM

Haven't used that, many claim to things like this, but give it some thought, to truly keep mobo updates current, they would have to be checking every mobo available daily for updates...Just not a fan of these optimization programs, many of thing mess things up more than they help and many don't really help at all.
m
0
l
July 2, 2014 3:28:55 PM

Tradesman1 said:
Haven't used that, many claim to things like this, but give it some thought, to truly keep mobo updates current, they would have to be checking every mobo available daily for updates...Just not a fan of these optimization programs, many of thing mess things up more than they help and many don't really help at all.


ok i am going to check this out will be doing a clean install of win then mobo drivers from manufacturer and then win updates
after that I will post my result
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
July 2, 2014 4:03:10 PM

Will be waiting to hear ;) 
m
0
l
July 9, 2014 3:04:11 PM

Thanks mate :) 
I had reassembled n cleaned all pc parts and then did a clean install of ssd
updated all drivers from asus website getting an unknown device in device manager
but what happened before and still now is im getting a blue screen x0000124 error while doing anything playing games or whatever
my montior is very old it has just vga connector which connects on my gpu i never used on board graphics and cant even install them as gpu disables it so i dont have a connector in this old monitor which can be connected only to mobo but there is no options for that certain old pins now ....
did all memory test all is fine but still getting this error i m not sure what might b the cause if it is not this mointor and on board gfx
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
July 9, 2014 3:39:44 PM

Do you have the latest GPU driver
m
0
l
July 9, 2014 4:58:46 PM

yes downloaded it directly from website n checkd its updates all are up to date

unknown device in yellow in dev manager
it doesnot showup much details in hardware ids
just this
ACPI\PNP0A0A

*PNP0A0A

and in install error
There is no driver selected for the device information set or element.

E0000203

in siblings

ACPI\PNP0A08\0
ACPI\PNP0C0C\aa
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_1
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_2
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_3
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_4
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_5
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_6
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_7
ACPI\GenuineIntel_-_Intel64_Family_6_Model_60_-_Intel(R)_Core(TM)_i7-4770K_CPU_@_3.50GHz\_8
ACPI\PNP0C0B\0
ACPI\PNP0C0B\1
ACPI\PNP0C0B\2
ACPI\PNP0C0B\3
ACPI\PNP0C0B\4
ACPI\ThermalZone\TZ00
ACPI\ThermalZone\TZ01
ACPI\PNP0C14\ASUSWMI
ACPI\FixedButton\2&daba3ff&2



parent
ACPI_HAL\PNP0C08\0

problem code
0000001C

if this helps
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
July 9, 2014 5:25:02 PM

Check mobo site under utilities for the latest ACPI Driver
m
1
l
July 10, 2014 4:42:01 AM

Thank u that fixed the other devices problem
But im still getting that stop code 124 a bsod
I cant figure out wats causing it
By seeing the dump files in blue screen viewer it shows hal.dll as culprit n an other driver

P.S
My.mobo had old bios when I bought it a month ago offcourse
By using ezupdate came with Aiii suite it updated bios to 0903 version and after this update it doesnot update bios any further it shows that there is no need to update but In asus website I see latest bios version of 1505 but that ezupdate is neither showing it nor updating it to 1505 but says it doesnot need any more update
So what should I do in this regard also? Can this b causing BSOD?
m
0
l
July 15, 2014 1:39:03 PM

so i figured out the problem
and im sharing the solution so that if anyone needs it in future
I previously updated maximus vi hero Bios with Ez update found in AI suite 3, for which "Ez Update/AI Suite 3" updated it to version 0903 which was unstable and giving me blue screen funny thing was that Ez update wasn't updating bios any further but showed some message that it doesn't require to update environment
so i download BIOS updater for 4th Gen Intel Core v1.5 from asus bios utilities and downloaded MAXIMUS-VI-HERO- bios version 1203
and MAXIMUS-VI-HERO- Bios version-1505
1st i updated it to 1203 version from BIOS updater for 4th Gen Intel Core v1.5 tool and then updated it to 1505 version after the restart i see no more blue screen on games which was showing previously since then i haven't seen a single blue screen or any other error
i hope it will help the guys in future if they stuck on same problem
m
0
l
a c 912 Ĉ ASUS
a c 1710 V Motherboard
July 15, 2014 1:52:28 PM

Glad all is well and thanks for sharing the info ;) 
m
0
l
!