Sign-in / Sign-up
Your question
Solved

Screen Artifacts after 1hr of gaming

Tags:
  • Gaming
  • Tom's Hardware
  • HD
  • Sapphire
Last response: in Graphics Cards
June 14, 2014 1:24:01 AM

Just recently got a Sapphire HD 6670 and i seem to be getting screen artifacts after an hour of gaming, i have overclocked it to 900 mhz core clock and 1700 mhz mem clock, definitley know its not overheating as load temps never go past 55c.

More about : screen artifacts 1hr gaming

Best solution

a c 283 4 Gaming
June 14, 2014 1:30:47 AM

Either lower the clocks or turn up the voltage; Artifacts are usually the result of an unstable overclock.
Share
June 14, 2014 1:34:31 AM

Thanks for your answer, im gonna try to up the voltage and see the results
m
0
l
Related resources
a c 283 4 Gaming
June 14, 2014 1:35:21 AM

No problem, let me know if it helps :) 
m
0
l
a c 790 4 Gaming
June 14, 2014 1:36:10 AM

Post your build. Maybe your case is small and card too hot for it. Or the power supply is going screwy.

Blow out the case - especially coolers and filters.

Raise the fan speeds.

Summer in the US?
m
0
l
June 14, 2014 1:48:00 AM

Here are the specs
Core i5-650
Asrock H55M-LE
And a powerlogic psu
My case is ATX and just cleaned it 3 weeks ago and temps are: CPU 63c under load and GPU 55c underload.
m
0
l
June 14, 2014 1:51:00 AM

Yeah, it really was undervolted, after some googling other people were having the same problem and increasing the voltage seemed to have fixed it, thanks guys for the feedbacks.
m
0
l
a c 283 4 Gaming
June 14, 2014 1:52:34 AM

Good to know it worked :) 
m
0
l